Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26

Thread: RPM Problem

  1. #1

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83

    RPM Problem

    i installed today the 14/20 impeller and 87 mm exit nozzel and my rpm is only 6800....bottem end and midrange is arm pulling but when i reach to app 6500 RPM it stops and steps slowly to 6800 RPM and stops there....

    any suggesions whats wrong ??


  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Most people have a hard time turning that screw with your level of mods.

  3. #3

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83
    do u think i should install back the 13/19 and remove also the 87mm nozzel...or can i use the stock pitch with 87mm nozzel

    Quote Originally Posted by WFO View Post
    Most people have a hard time turning that screw with your level of mods.

  4. #4
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Quote Originally Posted by Cdoo EtR View Post
    do u think i should install back the 13/19 and remove also the 87mm nozzel...or can i use the stock pitch with 87mm nozzel
    I would use the stock prop with the 85mm, till you find some more power.

    Unless you are ready for reeds and such, you may want to get in touch with some of the other guys running your level of mods for some air mod tricks... like Rossnemo

  5. #5

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83
    i already orderd the VF reeds thanx to fercho...
    i dnt know but do u think if i use the 85mm with the 14/20 i would get up my RPM

    Quote Originally Posted by WFO View Post
    I would use the stock prop with the 85mm, till you find some more power.

    Unless you are ready for reeds and such, you may want to get in touch with some of the other guys running your level of mods for some air mod tricks... like Rossnemo

  6. #6
    Grand Cayman Tanny's Avatar
    Join Date
    Dec 2006
    Location
    Cayman Islands
    Posts
    276
    Cdoo i have some of your mods listed on my craft it will be shipped here to me next 2 weeks what is your top Speed just want a estimate on where mine will reach?

  7. #7
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    The 85mm will drop your rpms 60-80 more.

    Get them reeds in there and some air in the motor and you should be fine with the 14/20. Then you can play with the nozzles.

  8. #8
    Chrisrokc's Avatar
    Join Date
    Apr 2006
    Location
    Oklahoma City, OK
    Posts
    3,667
    I have the SAME problem I think. I have had my tach in the wrong spot so I might be almost 7000. Anyways, still low. I bought the VF3s from Fercho(hes the man) and I plan on running no flame arrestor or box till I buy Ross's throttle bodies. I also am testing a different good EFI controller tomorrow to see if that is my problem. I will post of details after I get back from the lake.

    BTW I have tested the 87mm vs 85mm and in RPM there was no difference. Mind you the 87mm nozzle was the R&D one.

  9. #9

    Join Date
    Aug 2006
    Location
    UAE
    Posts
    83
    i forgot the GPS hopefully next time i will check my speed
    Quote Originally Posted by Tanny View Post
    Cdoo i have some of your mods listed on my craft it will be shipped here to me next 2 weeks what is your top Speed just want a estimate on where mine will reach?

  10. #10
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Quote Originally Posted by Chrisrokc View Post
    I have the SAME problem I think. I have had my tach in the wrong spot so I might be almost 7000.


    BTW I have tested the 87mm vs 85mm and in RPM there was no difference. Mind you the 87mm nozzle was the R&D one.


    That's peculiar... you sure you were getting a good rpm reading ?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Challenger 180 High RPM problem
    By FLSUN in forum Sea Doo Sport Boats
    Replies: 17
    Last Post: 08-13-2008, 10:45 PM
  2. rpm problem
    By itsbestkept in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-26-2008, 07:46 AM
  3. 02 xlt 1200 rpm problems
    By saxy415 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-10-2008, 06:27 AM
  4. Rpm ???? Problems
    By rauldino132 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-20-2007, 06:15 PM
  5. RXP Rotax RPM problem... we're helpless
    By Shibby1485 in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-28-2005, 08:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •