Results 1 to 2 of 2

Thread: Battery issue

  1. #1
    polarispa's Avatar
    Join Date
    Aug 2006
    Cranberry PA

    Battery issue

    I just plugged my battery into the charger and it is saying its fully charged, but Ive ran a test with a bulb tester and it does not light up, it wont turn the motor.
    Does this mean my one year old battery is no good?

  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    I'd clean the terminals first, then check again.
    Otherwise you probably have a broken plate in the battery.
    Maybe the battery charger hasn't kicked on. Some batteries when completely dead will not start the charger process. I will usually "kick start" it with a good battery while the charger is hooked up to the battery.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. battery issue solved
    By bossdog67 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 10-18-2009, 04:39 PM
  2. SLX 750 battery issue
    By jddesign in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-09-2009, 08:47 PM
  3. RXPX Battery Issue/Question
    By RXTJeff in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-04-2008, 12:54 PM
  4. Battery Issues
    By rcngmoto in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-26-2008, 10:19 PM
  5. Battery issue
    By fastkaz in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 02-19-2007, 10:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts