Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 35

Thread: P0326

  1. #1
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54

    P0326

    i got this code 3 times when out running this past weekend, "knock sensor out of range" i have the updated harness on my 04, towards the end of the day i didnt have it though, ski was running fine, balls to the wall fast accelleration...for stock IC anyway...would too much oil cause anything like that? any ideas......


  2. #2
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,759
    +1
    29
    Glad you posted this,,,how do I get the codes from an `05 RXT?

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    Quote Originally Posted by HOSS View Post
    Glad you posted this,,,how do I get the codes from an `05 RXT?
    at the time of the alarm.. press the set buttons 5 times... look at the screen and it'll display a p-code

    once you remove the key, the fault code is erased from the gauge memory, but IS stored in the ECU memory... only way to see a previously occured code is thru BUDS at the dealer...

    important that when u get an alarm or code, you retrive it before you turn the machine off

    06+ skis dont have mode/set buttons obviously... so if it's a p-code it will display automatically on the gauge

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    MEEPER....wait... ski was running fine, so you remove the knock sensor and get the error message?

    why'd u unplug the knock sensor harness? you need it... if it's not plugged in, then u'll get an error code

    confused by your post, can you clarify?

    no, too much oil isn't going to cause a knock sensor code... a knock sensor code is for a knock sensor error, nothing else but

  5. #5
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,759
    +1
    29
    Damn,,its gone. I figure it is poor fuel though. Installed an intake and RR wheel on it. Gas was in there for about 8 months.

  6. #6
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    shibby, i didnt unplug the harness or mess with it, its still there....it didnt happen constantly, it would come one once in a while, happened 3 times when ridining but i rode all day....would it be a faulty sensor? should i recheck my wires? too much fuel with my sc?

  7. +1 by:


  8. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    .. ok, i understand now...

    was that your first ride of the season?

  9. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Probably just a bad knock sensor.

  10. #9
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    yes first ride...i have GPS numbers, not going to post because not sure on accuracy due to current and RPM...would running rich or lean make the sensor go off...??

  11. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    You are not running rich or lean and even if you were it wouldn't cause that sensor to show bad.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P0326 code and check engine
    By RXPwilly13 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-12-2011, 09:59 PM
  2. rotax ecu and knock off sensor warning P0326
    By otoss in forum 4-Tec Performance
    Replies: 5
    Last Post: 02-13-2011, 04:13 PM
  3. 2008 rxp-x p0326 check engine error??
    By Supercowcc in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-13-2010, 09:36 AM
  4. 2005 rxp chk eng p0326
    By LOFLYN in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-04-2010, 06:52 PM
  5. Check Engine P0326
    By richrxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-08-2008, 01:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •