Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1
    Mongoose's Avatar
    Join Date
    Aug 2005
    Location
    Wales
    Posts
    665
    +1
    6

    I need to get my RPM's up-Any ideas.

    I have a 99 Gp1200.
    Riva intake grate, Riva flame arrestors with the highs turned out a 1/4past oem.
    Solas YD-CD-13/19.
    I am only seeing 6850 rpm.
    I want to see 7000 rpm, but I want to try and get it without touching the prop, or putting my aftermarket head on.
    I am going to do the water bypass mod, but is there anything else I can do to help?


  2. #2
    DAGO RACING CREW 97GPSLEEPER's Avatar
    Join Date
    Apr 2006
    Location
    Orange, TX
    Posts
    4,228
    +1
    169
    Have you thought about adding some V-Force reeds? Carl at Island Racing has put together a reed assembly for the old school motors. You should gain some RPM with this. Also, remove the bilge siphon tube in the pump nozzle, and fill in the visibility spout hole, sand both of these areas smooth. This will help a little.

  3. #3
    Old Ski Insanity w/rpm500's Avatar
    Join Date
    Aug 2005
    Location
    Crystal River Fl
    Posts
    2,208
    sounds as thou you wish to stay out of the motor till later... you could get FERCHO'S offset cut timing key .. this will advance your timing approx. 3 deg .. what impeller are you running? a different hub style may give you a tad more rpm or try a change in your nozzel dia.,this will let the motor unload a little, but may scrub your speed.... seeing as you ocean run IMT,you'd be looking for quickness and not an all out speed set up.

  4. #4
    Mongoose's Avatar
    Join Date
    Aug 2005
    Location
    Wales
    Posts
    665
    +1
    6
    Iv'e been thinking about the keyway.
    Im also concened about the prop. I feel with the prop I have, I should be seeing more rpm's.
    60mph is all I want- I just want to get there in a hurry!
    Is the prop too much??
    Don't know much about the Solas YD-CD-13/19.
    Last Solas prop I bought was designated differently-it just said X0.
    What I am trying to get is 7000 before starting on the engine.
    I just want to make sure there are no hull issues holding me back. I don't want to chuck parts on to force it up if it means hideing a underlying problem.
    Engine has 40 hours on it from new, and 125psi on my Snap-On gauge on all 3.

  5. #5
    DAGO RACING CREW 97GPSLEEPER's Avatar
    Join Date
    Apr 2006
    Location
    Orange, TX
    Posts
    4,228
    +1
    169
    What are you currently running on GPS? The 99's ran 59-61 stock. Do you have a stock rideplate & intake grate? Do you have the trim tabs? I can help you hit 60 without doing a single thing to the motor. You really should be running 60 stock though.

  6. #6
    Mongoose's Avatar
    Join Date
    Aug 2005
    Location
    Wales
    Posts
    665
    +1
    6
    Quote Originally Posted by 97GPSLEEPER View Post
    What are you currently running on GPS? The 99's ran 59-61 stock. Do you have a stock rideplate & intake grate? Do you have the trim tabs? I can help you hit 60 without doing a single thing to the motor. You really should be running 60 stock though.
    Im running 57 on the GPS.
    When I said 60-It's not my ultimate goal. If it goes faster great.
    What i am saying is that, riding in the ocean, 60mph is all I want. I prefer to keep the speed down to 60 and gain holeshot and rpm's.
    Ski set as per first post.
    Iv'e got a set of riva tabs, and a Pro-tec plate on the bench.
    What do I need to see 60mph/7000rpm?
    Thanks

  7. #7
    DAGO RACING CREW 97GPSLEEPER's Avatar
    Join Date
    Apr 2006
    Location
    Orange, TX
    Posts
    4,228
    +1
    169
    Go to post #9 in this link, and click the link. These little mods will help you get to 60. With you running in the ocean in less than ideal conditions, the 57 you are running is not bad. When I say a 99 GP will go 60, I mean in ideal water conditions with a half a tank of fuel or less.

    http://greenhulk.net/forums/showthread.php?t=21734

    Your options on inproving holeshot are going to be limited to a prop (Solas XO) and the jetworks mod with out getting into the motor. You can shim to rideplate down in the back to help it get on plane faster, but this will cost you on the topend. I would not worry about trying to hit 7000 RPM's. The stock rev limiter is 7050.

  8. #8
    Old Ski Insanity w/rpm500's Avatar
    Join Date
    Aug 2005
    Location
    Crystal River Fl
    Posts
    2,208
    follow what sleeper has to say and concentrate on your hull setup .. the jetworks will help you in quickness and the XO, IMO, is the ideal impeller for most gp riders..an all out ski would need a different impeller with a custom pitch .. there is not alot of rpm gains left to be had with out opening up your engine .. port timing, flywheel lightening , your milled head , v3 reeds, case porting , addition of lighter pistons and the modifyed cdi /rev limiter to let you rev that high.....You may still try a nozzel dia change(larger) before anything more is done ...as I'M thinking that as rough as ocean surface can get you need to be sure to be able to process water with more than its share of air in it... you are running fast for what your in...

  9. #9
    Old Ski Insanity w/rpm500's Avatar
    Join Date
    Aug 2005
    Location
    Crystal River Fl
    Posts
    2,208
    remember too, that salt water is denser so you will run a tad slower rpm than in fresh...

  10. #10
    ....back from the dead.... J-ME's Avatar
    Join Date
    Aug 2005
    Location
    Delaware
    Posts
    1,577
    +1
    2
    What's your altitude?

    That Riva grate is part of the problem.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. starting to get some rpms on my 300x
    By 300XXX in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-21-2011, 08:43 PM
  2. Do i need to get an aftermarket Ride plate for my FZR
    By bigbear in forum Yamaha PWC Performance (4-stroke)
    Replies: 24
    Last Post: 04-23-2010, 05:38 PM
  3. RPM coupler setscrew heads are stripped and I need to get this cylinder off ASAP HELP
    By ProXR 440 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-29-2009, 01:20 PM
  4. I need to get my impeller repitched.
    By Pinoy in forum 4-Tec Performance
    Replies: 23
    Last Post: 03-08-2008, 08:33 PM
  5. HELP i need to get me and my ski to the bug
    By rapidacceleration in forum Mudbug Nationals PWC.Life Rally
    Replies: 1
    Last Post: 05-30-2007, 10:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •