Results 1 to 6 of 6
  1. #1

    Could someone check this on their RXP for me please...

    As some of you know my steering nozzle blew up on me last summer, and I put on a new one over the winter. I noticed that their is a little bit of verticle play in the steering nozzle. Is this normal?


    Thanks


  2. #2
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    there is a little bit...especially the reverse bucket..

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    is the VTS rod moving with the vertical play?

  4. #4
    Quote Originally Posted by Shibby1485 View Post
    is the VTS rod moving with the vertical play?
    Yes, a little bit where the bolt links the two parts of the VTS cable before it enters the hull.

  5. #5
    Quote Originally Posted by meeper View Post
    there is a little bit...especially the reverse bucket..
    I removed my reverse bucket. I was wondering about the steering nozzle itself.

  6. #6
    Quote Originally Posted by RXPkid View Post
    As some of you know my steering nozzle blew up on me last summer, and I put on a new one over the winter. I noticed that their is a little bit of verticle play in the steering nozzle. Is this normal?


    Thanks

    Yes both of my RXP's had that.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Could someone provide info on the eng compartment
    By Troy Hammond in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-07-2008, 07:32 PM
  2. Did anyone find this on their Ride Plates?
    By yellow4 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-16-2007, 12:15 AM
  3. What is this on my RXP?
    By vidbuster in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-11-2007, 09:44 PM
  4. Removing knock sensor on 2005 rxp for rr ecu
    By Chezzy in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-13-2006, 07:34 PM
  5. Anyone else notice this on their RXP?
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-30-2005, 11:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •