Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Down 3mph from last year, any suggestions?

    Yup, just what the title says.

    I know performance during the first ride of the year has been discussed before (last years fuel w/stable, fogging oil, antifreeze thru exhaust system), and how it hinders performance some, but is 3mph normal? I can't believe it is because after the 2005-06 winter when I went out for the first time I was running 67-68+mph completely stock. This year my mods are listed in my signature and Im running 67-68+mph. My RPM are all there 8100-8150.

    Any ideas? Thanks.


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by RXPkid View Post
    Yup, just what the title says.

    I know performance during the first ride of the year has been discussed before (last years fuel w/stable, fogging oil, antifreeze thru exhaust system), and how it hinders performance some, but is 3mph normal? I can't believe it is because after the 2005-06 winter when I went out for the first time I was running 67-68+mph completely stock. This year my mods are listed in my signature and Im running 67-68+mph. My RPM are all there 8100-8150.

    Any ideas? Thanks.

    wear ring?

  3. #3
    Looking for a job gtxsc03's Avatar
    Join Date
    Dec 2005
    Location
    St. Charles, MO
    Posts
    1,426
    Did you gain a lot of weight this winter?

  4. #4

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965
    How's it going? Anyway, how long did you ride and what did you use for readings?

  5. #5
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Wear ring

  6. #6
    Quote Originally Posted by Danny View Post
    wear ring?
    But wouldn't my RPM be off? Don't you guys lose RPM if the wear ring needs replacing? Also, the last time out last summer I was running 71+mph, and the ski hasn't been rode and the wear ring hasn't been touched since then. Now Im down 3mph.

    Quote Originally Posted by gtxsc03 View Post
    Did you gain a lot of weight this winter?
    Nope.

    Quote Originally Posted by smc View Post
    How's it going? Anyway, how long did you ride and what did you use for readings?
    I rode for over a half an hour. I ran the ski for a couple minutes on the hose before I went out just to check for loose hoses, leaks, etc. I did the runs just before I cam back in. I had been varying throttle and everything before I did the runs, so the ski was warmed up.

    Water was only about 40 degrees F at most, air was upper 60 degree F, and there was very little humidity. I used a GPS to get the speed, and was also going by the stock tach for RPM.

    Quote Originally Posted by ReDevilRXP View Post
    Wear ring
    Again, wouldn't I be missing RPM if it needed replacing?

  7. #7
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Im not sure but i dont think worn wear rings cause lose of rpm's. How many hours do you have on the wear ring?

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Change your wear ring.

    Also, make sure your grate isn't hanging down in the back

  9. #9
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by RXPkid View Post
    But wouldn't my RPM be off? Don't you guys lose RPM if the wear ring needs replacing?


    Again, wouldn't I be missing RPM if it needed replacing?
    I would think you gain RPM with too much ring clearance.

    Are you running a wedge & extention rod? I ask because I noticed that with the wedge & WITHOUT the ext. rod on my S2 setup, mid trim was equal to 3/4 up. If I went to 3/4 up or more I would lose 80-100 rpm & 2+ mph. The sweet spot was 1/2 up to 1 click above. But, With the ext. rod it was all good to full up position.

  10. #10
    Quote Originally Posted by Green Hulk View Post
    Change your wear ring.

    Also, make sure your grate isn't hanging down in the back
    Alright, I planned on swapping out this current ring this spring anyways because I have 55+ hours on it. I'll take a look at the grate once I see the ski again.

    Quote Originally Posted by ou812 View Post
    Are you running a wedge & extention rod? I ask because I noticed that with the wedge & WITHOUT the ext. rod on my S2 setup, mid trim was equal to 3/4 up. If I went to 3/4 up or more I would lose 80-100 rpm & 2+ mph. The sweet spot was 1/2 up to 1 click above. But, With the ext. rod it was all good to full up position.
    Im running a wedge only. I still find my best speeds with or without the wedge to be two clicks above neutral, but I have never noted a difference in RPM by adjusting the trim on my ski.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Waccamaw River Ride from last year
    By dlf2001 in forum Videos & Pictures
    Replies: 3
    Last Post: 08-14-2014, 12:39 AM
  2. Replies: 14
    Last Post: 06-02-2013, 08:37 PM
  3. 94 slt wanted back from last years death
    By Djaypro in forum Polaris Open Discussion
    Replies: 18
    Last Post: 06-24-2012, 02:02 PM
  4. First time out in two years, any suggestions?
    By Jkunzy1690 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-03-2009, 05:09 PM
  5. I lost 50 rpm from last year
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-30-2006, 09:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •