Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Stock Impeller Change

    Ok, I am ready to place my order from the online store through this site and I want to make sure I buy everything I need.....

    I have an 05 Sportster SCIC with the stock system. I am going to buy the Solas 13/18 prop along with the SS wear ring.

    I am not sure which prop removal tool to get....Any input appreciated

    Thanks


  2. #2

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    I doubt Jerry would knowingly let you order the wrong one, but here's whatcha need:

    1 x Stainless Steel Replacement Wear Ring for 215 HP Units (RS33-159-SRX) = $189.95
    1 x SRX-CD-13/18 (SRX-CD-13/18 ) = $235.00
    1 x Impeller Removal Tool RXP/RXT (Solas) (solas 215hp tool) = $16.95

    -Scott

  3. #3
    VX1---Thanks again for the info. I just placed my order.

    Any problems/issues with the install of the new impeller & wear ring? I believe you have had them in now for a month or so.

    Thanks

  4. #4

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    Nope, just print out the directions on this site, make sure you have all the tools (vise, allen set including 12mm, socket set with long extension, grease, freezer space, etc.) and in about four hours, you can be back on the water with your new smile-inducing acceleration!

    -Scott

  5. #5
    Ok.....I just received all my parts from the Green Hulk (impeller, removal tool, and SS wear ring). Tomorrow I will be attenpting to do the install.

    Dumb question......isn't the impeller suppose to fit inside the SS wear ring??? If so, mine does not. Either the impeller is to large in diameter, or the wear ring is too small in diameter.

    Sorry if this is a dumb question, just want to make sure I have the right parts before I take out the pump.

    Thanks!!!!

  6. #6

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    Mine fit in, and I was amazed at the tolerance between blades and ring, it had to be within a matter of atoms of touching, but the blade spun freely. The ring had just come out of the frezzer, if that makes a difference. I greased my ring for good measure, so perhaps that could help it slide in. I've heard of people having to file down a blade's edge after repitching, so you should also make sure your 13/18 is in spec.

    -Scott

  7. #7
    VX1----I'll have to play around with everything again, but when I first looked at it, the impeller only slid in about half way, and then seemed stuck. I'll grease it and see what happens....

    2 questions:

    Did your impeller spin freely in the wear ring....was there any resistance?

    How would I confirm that the 13/18 is in spec???

    Thanks!!!

  8. #8

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    My impeller spun freely, no resistance. If you can put it half way in, what's happening is you're tilting it as you go down into it. Once it's on the shaft where it won't tilt, it will spin as it should. And even if it didn't fit on one side, the impeller only needs one side, just like they flip the stock "plastic" wearring around and use it again, you'd put the side that it didn't fit in good toward the end of the pump away from the impeller. Unbelievably close is a good thing, you want it that close!

    To verify pitch... well, Watcon sells an impeller pitching tool, which is just a clear plastic bowl the impeller drops into where you can read the pitch. It rediculously expensive, for what it is, though. It should cost $50 tops and from what I remember it's more like $160. To get a basic idea, you could just use an accurate ruler and check that each blade starts and finishes the same as the others:

    http://www.greenhulk.net/forums/show...ler+pitch+tool

    I wish I checked mine better before I put it in.

    -Scott

  9. #9
    Well......a little grease and if fits in fine and spins inside the ring as well....

    Thanks for all the input!!!

  10. #10
    Ok....Last question on changing the impeller.....I have my pump off and I am using the removal tool along with the 12 mm allen on a large socket and I cannot get it to turn...???

    I tried turning counter clockwise, then even clockwise to make sure I wasn't misreading anything and I can't get it to budge....

    Any ideas?????

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha stock impeller
    By Brewster in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 09-12-2007, 07:30 PM
  2. impeller change
    By 9t8gp1200 in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 08-08-2007, 11:59 PM
  3. Wear Ring & Impeller Change
    By WaskesiuDoo in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 04-26-2007, 09:16 AM
  4. Stock impeller pitch?
    By J-ME in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 01-09-2007, 12:23 AM
  5. Upgrading from stock impeller to 14/21.5 skat, Washer ??
    By slow1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-28-2006, 01:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •