Results 1 to 10 of 10

Thread: Coolant Leak?

  1. #1
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,812

    Coolant Leak?

    Noticed from my last run that my coolant had dropped about 1/4" from the last ride and it is in the bottom of my hull. I checked all hoses and everything seems to be as tight as a drum. Could riding in extremely cold temperatures cause this to overflow slightly? Also, when it is time for a complete coolant change or addition, what is the best coolant to use and is the ratio a straight 50/50?


  2. #2
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,812
    Over 25 hits and nobody has some input??

  3. #3
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Devil:

    I would take a look at the coolant and see what it is rated to. Go to an auto store and get a tester for about $10. See how cold you are rated for.

    A couple of questions:

    1. did you do anything to your ski before you rode it that last time when you had problems?

    2. did you notice the problem after you rode or before you rode?

  4. #4
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,812
    Quote Originally Posted by Jeff C
    Devil:

    I would take a look at the coolant and see what it is rated to. Go to an auto store and get a tester for about $10. See how cold you are rated for.

    A couple of questions:

    1. did you do anything to your ski before you rode it that last time when you had problems?

    2. did you notice the problem after you rode or before you rode?
    Jeff,

    1. Nope, nada done to the ski other than a swap out of props.

    2. Noticed it after the ride (from a very cold one at that)

  5. #5
    everything shrinks when it is cold ....including your coolant

  6. #6
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,812
    At the same time I posted this, I also posted it to GP's site and this is what he said

    "Take a look at the two very rearward hoses that connect to your ride-plate from the inside of your hull at the base of the hoses where they fit on and see if the "spring clamps" are allowing coolant lose.
    Replace the cheesey spring type clamps with some high quality stainless ones.
    We solve quite a few that have a leak in this area.

    The clamp at the top of the engine on the main water/coolant hose as stock has a large Oetiker clamp on it that I have seen a few of those leak as well, but not near as many as the clamps in the rear. I also replace with a high quality stainless clamp. If it is leaking there it'll also freeze-up your SC unit to the engine block from the corrosion, bad thing! Hope this helps. GP@PPG"

    Well sure as shit today after I had drilled my hole through the hull for my thru hull exhaust, I take a look at where the rearward hose connects to the ride plate because I now have a well lit perfect view. There is a tiny puddle of green coolant laying right there. Problem solved.

  7. #7
    Red Devil, What`s up bro!, I remember reading about changing all those types of clamps and the bailer zip ties to clamps in GP`s bulletproofing thread. Do a search at SDN and you`ll see the list of things to do...PR...

  8. #8
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    premix anti-freeze

  9. #9
    Shibbs: where did you read pre-mix?...PR...

  10. #10
    Shibbs, I just found it in the service manual, 50% antifreeze/50% Demineralized water...PR...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Coolant leak
    By whynotcw in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-14-2008, 08:52 PM
  2. Coolant leak
    By da1nonlyrxp in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-14-2008, 11:43 AM
  3. coolant leak?
    By mxl16 in forum 4-Tec Performance
    Replies: 7
    Last Post: 01-08-2007, 06:47 PM
  4. Coolant Leak
    By luismendez25 in forum 4-Tec Performance
    Replies: 12
    Last Post: 10-08-2006, 08:36 PM
  5. Coolant Leaking...
    By Totallyblown in forum 4-Tec Performance
    Replies: 8
    Last Post: 03-22-2006, 03:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •