Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1

    Problem rxp keeps on shutting off

    i let my friend ride my rxp for a litttle bit well even with the learning key he flipped it and when he flipped he was stil under it and the key never came off so the engine was still running upside-down and i then it just kept on shutting off when ever i going 3000-4000 rpm, so i think it could be the fuel injector or the gas line got in some air when it was tipped over and it sounds rattely when i crank it up out of the water. anyone ever had this problem or knows what i could do?


  2. #2
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Did you suck in water?

  3. #3
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    does not sound good to me.....if ur ski was running while it was flipped over you most likely got some water in there which would suck....im sure plenty of guys will help you out with this though.

  4. #4
    well i took off the seat and see if there was anywater in there and i couldnt tell so i took it back to the dock and put it back on the trailer and there wasnt any water in there.

  5. #5
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788
    How about water in the gas???

  6. #6
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788
    They all sound rattley out of the water...

  7. #7
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Here is what I would do.

    Chyeck the oil and see if it is milky. If it is, change it immediately!

    If it is not, I would back your ski into the water on the trailer and start it up and let it idle. Let it warm up completely. Run it for 30 minutes on the trailer. Over the first few minutes, check the oil a few times to see if it got milky.

    If it runs ok, try giving it more and more RMPs, and see if it works its way through.

    Do you run on Salt water or fresh water?

  8. #8
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    It is normal for it to be "rattly" when out of the water. Just dont rev it up very high when it is out of water. There is no load on the pump.

    Also, when you are in the water on your trailer, be careful not to ull debris off the bottom into the pump. If ytou have a concrete ramp you are way better off than if you had a sand ramp.

    dont run the ski out of the water for more than 30 seconds, even with water from the hose, or you will overheat your carbon ring.

  9. #9
    jack's Avatar
    Join Date
    Jun 2005
    Location
    West Palm Beach Florida
    Posts
    712
    What happened to the TOPS?

  10. #10
    way2fast's Avatar
    Join Date
    May 2005
    Location
    Melbourne Beach, FL
    Posts
    4,013
    +1
    3
    Quote Originally Posted by jack
    What happened to the TOPS?
    That only works when you are out jumping waves...not when it is supposed to shut the engine down !!


    Richard

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. STRAINER & shut-off for towing ? 12 RXP-x
    By Bogger in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-04-2013, 09:03 AM
  2. 96 xp keeps shutting off after starting.
    By aruba yamaha in forum 2-Stroke Performance
    Replies: 4
    Last Post: 09-04-2012, 06:57 PM
  3. Polaris Virage TX Starts Great, Keeps completely Shutting Off
    By apelleri in forum Polaris PWC Performance
    Replies: 1
    Last Post: 09-01-2012, 12:39 PM
  4. Fuel shut off value for rxp and rxt
    By sturyan in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-25-2011, 04:19 AM
  5. 1996 waveraider 1100 triple shut off problems
    By waveraider1100t in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-16-2009, 07:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •