Results 1 to 4 of 4
  1. #1
    absentx's Avatar
    Join Date
    Aug 2006
    Location
    Milwaukee
    Posts
    742
    +1
    8

    crap...is my fuji stator shot??

    All my resitance readings are spot on spec, but the red/purple to yellow which is supposed to be .5 ohms is reading .8

    Put it in the engine or put it in a box and ship it out to get fixed???

    Pro 785 engine


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Stick it in and bench test for spark.

  3. #3
    absentx's Avatar
    Join Date
    Aug 2006
    Location
    Milwaukee
    Posts
    742
    +1
    8
    yeah, Randy just told me to bolt er in and go as well.

    Bench test, great idea.

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    .3, I'd run it as well. I can't even remember when I've replaced a Fuji stator.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is my chipped jet pump stator junk or is it no big deal ?
    By Gen2 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-24-2015, 05:28 PM
  2. What the hell is the crap in my engine bay???
    By UNSANE in forum 4-Tec Performance
    Replies: 10
    Last Post: 10-26-2011, 04:52 PM
  3. Is my carbon seal toast?
    By Lurker in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 09-02-2006, 03:47 PM
  4. (PIC) All I want for christmas is my 2 front teeth..honestly
    By MPower in forum Yamaha Open Discussion
    Replies: 17
    Last Post: 06-05-2006, 10:37 PM
  5. Is My Ski BULLET PROOF Now?
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 05-25-2006, 10:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •