Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Bad Idea?

  1. #1
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477

    Bad Idea?

    So im debating on where to put my bilge thru hull fitting and i think i want to put it by the gas and battery vents or in the same place on the opposite side of the hull. Is it a bad idea to put it under the rub rail ? I see everyone putting it somewhere high on there skis. I dont really want it to be seen im getting the tip of my fitting powder coated black so it will blend right into the hull. Plus since its up front i will see if its pumping or not. The main thing that concerns me is if i turn is it possible that the fitting will be underwater therefore taking in water if its not pumping ? Thanks for any input.


  2. #2

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    put a one way check valve in the hose like they do on a Yamaha GP1200r and 1300r this will stop the water from flowing back in the hose/hull

  3. #3
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    You could loop the line above the fitting so no water comes in. The only issue which you prolly already know, is having a long run takes away the pumping power of the bilge. I get a little water in the hull now with my fitting in the rear. I didnt loop it...

  4. #4
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Quote Originally Posted by RXP Steve View Post
    You could loop the line above the fitting so no water comes in. The only issue which you prolly already know, is having a long run takes away the pumping power of the bilge. I get a little water in the hull now with my fitting in the rear. I didnt loop it...
    Yup thats why im kinda iffy on putting it up front its gona kill the pumping power. I think i might just put it same place but above the rub rail. if its black you'll never notice it and i wouldnt need to loop it.

    Ivnspeed do you know where u can get a check valve like that?

  5. #5
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Shib said those check valves hurt the pumping power too..just throwin it out there..

  6. #6
    Quote Originally Posted by RXP Steve View Post
    You could loop the line above the fitting so no water comes in. The only issue which you prolly already know, is having a long run takes away the pumping power of the bilge. I get a little water in the hull now with my fitting in the rear. I didnt loop it...
    correct!...

    Where are you locating the pump?
    Take a look in the "How to" section under bilge pumps...
    just make sure you use and adequate reliable pump...PR...

  7. #7

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    You can either get it from a Yamaha dealer or just go to Home depot and get a one way check valve



    BTW its Lvnspeed

  8. #8
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Im putting it right next to the pump tunnel behind the waterbox.

    Sorry Lvnspeed

  9. #9
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    One last thing. Does it matter if i use 14 gauge wire? it says to use 16 gauge wire for normal installation and 14 when its over 25 feet. I have tons of 14 gauge wire does it really matter? Its a Rule-mate 500 gph. Thanks again.

  10. #10
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Going thicker is never a bad thing.(thats what she said) It should be just fine. I think I used the same myself..

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Video: Why Beach Launching a Jet Ski With a Camaro Is a Bad Idea
    By Rustymuscle in forum The Watercraft Journal
    Replies: 0
    Last Post: 01-27-2015, 09:20 AM
  2. Yamaha Leasing "Good Idea or Bad Idea"
    By unk50 in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 05-29-2014, 01:02 PM
  3. Replies: 21
    Last Post: 05-12-2014, 06:00 AM
  4. Standup on swim platform of boat. Bad idea?
    By SaltH2OHokie in forum Open Discussion
    Replies: 5
    Last Post: 07-22-2013, 08:28 PM
  5. RXP Exhaust Extender....Good or Bad idea?
    By inteljd in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-29-2012, 12:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •