Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Mar 2007
    Location
    mpls,mn
    Posts
    38

    limp mode solutions/ suggestions on 95 slx

    took the 95 to the lake and it is running in limp mode wont go over 4200 rpm. My problem ... i put in gas about 4 to 5 gallons and the fuel gauge is reading E i figure that the float is "gas logged" is this correct to assume? i assume this because it is in limp mode. How hard is it to replace the float/ cost or can i pull the wire Gray i believe to the cdi? Any suggestions welcome! thanks guys. btw the ski is in the classifieds the original owner told me it was carbs so... thanks again.


  2. #2
    The float is 27.00 but you might have to unbolt your tank and slide it forward to access! Randy at WATCON has them Z

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Is the red lamp flashing? It'd be a good idea to flush the fuel system and go through the carbs? Maybe change the lines if they are original.

  4. #4
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400

    float

    the float can be changed without moving the tank,you have to work it a little but it will come out

  5. #5

    Join Date
    Mar 2007
    Location
    mpls,mn
    Posts
    38
    Is it watcon.com? where do i find suppliers on our site?

  6. #6

  7. #7

    Join Date
    Mar 2007
    Location
    mpls,mn
    Posts
    38
    replaced float today!!!! solved my problem the ski is running great that was a easy fix! thanks to all for the help and thanks to randy at watcon for the part!!!!

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407

  9. #9
    Awwww, crap.. Don't tell me I just can't cut the sender wires.. Is it possible to bypass the sender? I am going to replace it.. But I have half-way disassembled my machine thinking it was a different problem. My machine dies around 4200, after I cut the wires, pink and black I think. It stopped flashing that damn light, But it did run like crap.. Surely to hell, they wouldnt derate a machine because it was low on fuel..

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    They would, try installing a 33 ohm resistor between the two wires leading to the electrical box.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 08-04-2012, 04:32 PM
  2. Limp mode on a 97 STS.
    By ccassone in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-29-2009, 07:43 AM
  3. limp mode, oil light troubles.. 780 slx
    By zimmyjim in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-09-2009, 08:15 PM
  4. Hello, 96sl780 in limp mode without blinking light on MFD
    By Silver_Pearl in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 05-17-2009, 11:04 PM
  5. compression on 95 slx
    By ercoach in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-16-2008, 11:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •