Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682

    %#$@!)* Driveshaft!!!

    Well today i go to pull the motor on the GTX and everything goes fine.....except for the driveshaft. I have the tool for removing the circlip but the little "hat thing" is not cooperating. I sprayed it down with lube due to the rust and called it a day. Try again tomorrow. Maybe i'll make something to hold the driveshaft as the pump doesn't seem to be doing it. The following pic describes how i feel about it.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	dscn0164_137.jpg 
Views:	118 
Size:	374.5 KB 
ID:	1543  


  2. #2
    Moderator two2curupt's Avatar
    Join Date
    May 2005
    Location
    Toronto, Canada
    Posts
    2,982
    +1
    41
    Put a few styrafoam packing peanuts into the hole on the impeller that slides onto the driveshaft....Then tighten the pump back up...The peanuts should help...then just pop the peanuts out when you are done..

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    i already told him to cut the driveshaft in half and rip it outta there since he's upgrading to the RXT driveline setup

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,994
    +1
    1,903
    damn i have never seen one rusted up like that

  5. #5
    Moderator two2curupt's Avatar
    Join Date
    May 2005
    Location
    Toronto, Canada
    Posts
    2,982
    +1
    41
    Is that rust????? I thaught that was grease...lol...get the saw out...

  6. #6
    For real? is that rust?...PR...

  7. #7

    Join Date
    Jun 2005
    Location
    Cayman Islands
    Posts
    705
    Thats nothing guys we see that all the time in Saltwater, my shop has broken two of the tools doing this.

  8. #8
    How many hours are on that shaft?...PR...

  9. #9
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    Yeah thats rust and no doubt it's underneath the floating ring jamming it up. I sprayed some penetrating lube on it and i'll try again tomorrow. I don't think the floating ring tool will do the job though. i like the idea of putting something inside the impeller splines but i also thing the floating ring needs a few hammer blows to jar it free so that the floating ring tool can do it's job. I'm afraid if i continue to put pressure on it the pto seal may be damaged.

  10. #10
    cut the drive shaft and fitt the two piece drive shaft you will feel the difference.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to remove a driveshaft?
    By 01xdime in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-30-2009, 07:44 PM
  2. Does the driveshaft moves in and out?
    By Hecyan in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-21-2006, 12:26 AM
  3. RXP & RXT driveshaft lengths??
    By rapidacceleration in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-04-2006, 07:38 AM
  4. Impeller removal, driveshaft
    By Kinchyle in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-25-2006, 08:38 PM
  5. Anyone pulled RXP Driveshaft out?
    By RXPDAVID in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-12-2005, 05:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •