Results 1 to 9 of 9
  1. #1

    Pictures of my Sound System..

    Here are the pics of my Radio,remote and subwoofer and speakers... (sorry no pic of amp)

    The sound is AMAZING and it blows my buddies away... Dont need more than one of these Tens to make the system pound loud..
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Boat subwoofer.jpg 
Views:	299 
Size:	51.5 KB 
ID:	23301   Click image for larger version. 

Name:	Boat speakers.jpg 
Views:	287 
Size:	51.9 KB 
ID:	23303   Click image for larger version. 

Name:	Boat radio and remote.jpg 
Views:	288 
Size:	52.8 KB 
ID:	23305   Click image for larger version. 

Name:	Boat with Bimini.jpg 
Views:	205 
Size:	69.4 KB 
ID:	23306  


  2. #2
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    the jl's are nice too and onething about jl it doesnt take much to power them

  3. #3
    Dr Len's Avatar
    Join Date
    Jan 2006
    Location
    New Jersey Attitude Capital of the World
    Posts
    1,170
    Looks good WR Cant wait till I get to put my stuff in

    Here's what I got

    2 Clarion 10 inch subs
    4 Clarion 6.5's
    1 Pyle 2 Channel 600 watt amp for the subs
    1 Pyle 4 Channel 1000 watt amp to run the 6.5's
    1 Clarion 475 Head unit

    Let's Rock

  4. #4
    braveit1's Avatar
    Join Date
    May 2007
    Location
    Jacksonville, FL
    Posts
    44
    welterracer, Where did you put your amp? How did it feel cutting that big hole for the sub woofer into a brand new boat? But I bet it sounds good. I'm thinking about a place for some front speakers so I can hear the radio while moving. I changed out my HU for a Pioneer 3900 and speakers got shot after sitting in the sun so I upgraded to Polk db-651's.

  5. #5
    Quote Originally Posted by braveit1 View Post
    welterracer, Where did you put your amp? How did it feel cutting that big hole for the sub woofer into a brand new boat? But I bet it sounds good. I'm thinking about a place for some front speakers so I can hear the radio while moving. I changed out my HU for a Pioneer 3900 and speakers got shot after sitting in the sun so I upgraded to Polk db-651's.

    I was nervous cutting the whole, i made sure and draw a perfect circle and a steady hand and outlined the whole with low tack tape to keep from scratching the gelcoat..

    The system sounds awsome.... everyone who has heard it cant believe how hard the bass hits.. for one 10" sub..

    It did suck routing the wiring though.. Big pain in the ass.. Ran the wiring under the flooring and threw the drain hole and over the gas tank and next to the stock wiring harness and covered everything with black wiring loom to make it look stock..

    I mounted the amp in the engine compartment on the back side of the original air box (where the rectifier is) And before you ask.. No the amp doesnt get hot in the engine compartment..

  6. #6
    Welterracer,

    Just wanted to see if your engine bay mount for the amp has proven to work over time.. I have the same sub and matching 6.5 clarion component speakers (more holes to drill for the tweets, ouch!) and the clarion 2ch marine amp, none of which I've had to time to install.
    I was planning to put the amp in the area under the front glove box ( where the fuse box is), but would prefer to have the shorter cables of your set up if it doesn't cook the amp.. Nice job with your system btw, I can't wait to finish mine.

    Thanks,

    D

  7. #7
    Quote Originally Posted by Djames View Post
    Welterracer,

    Just wanted to see if your engine bay mount for the amp has proven to work over time.. I have the same sub and matching 6.5 clarion component speakers (more holes to drill for the tweets, ouch!) and the clarion 2ch marine amp, none of which I've had to time to install.
    I was planning to put the amp in the area under the front glove box ( where the fuse box is), but would prefer to have the shorter cables of your set up if it doesn't cook the amp.. Nice job with your system btw, I can't wait to finish mine.

    Thanks,

    D
    STill going strong.. My amp doesnt even get hot in there..

  8. #8
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    got any pics of the amp??

  9. #9
    alloy89's Avatar
    Join Date
    Jan 2008
    Location
    San Antonio, TX
    Posts
    31
    Welterracer, I know this is off topic but how do you like your Bimini Top? How's the performace of the top under speed and did you install it yourself? Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pictures Of My 6 Month Project Gpr!!
    By RDH in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 09-18-2007, 08:21 PM
  2. Here is a picture of my bike
    By Lvnspeed in forum Other Toys
    Replies: 41
    Last Post: 04-03-2007, 03:38 AM
  3. Pictures of my ski :)
    By Dark_viper42 in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 04-01-2007, 11:28 PM
  4. Pictures of my Raider float anchor..
    By BULLRAIDER in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 01-15-2007, 09:29 AM
  5. Pictures of my head being ported
    By Green Hulk in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-13-2005, 08:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •