Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Cavitation sometimes....

    Had the 250 out today for the secong time. Wow this thing accelerates like no other, cant wait for the 5hr break in to be over so i can see what she really has! Anyways the ski cavitated very badly a couple times on the hole shot, i know that some of you experienced this and the cause was grease in the pump? Could you please elaborate...


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Some skis have had a glob of grease on the rubber grommet on the front of the prop, and a lot of excess silcone in the gullet where the shoe meets the hull, pull your intake grate down and have a look see.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	inside pump wedge red.JPG 
Views:	119 
Size:	28.7 KB 
ID:	23866  

  3. #3

    .

    had the ski out for the 3rd time today, 4 hrs and countin....anywho i got under it and took a look see after i was done riding. I didnt see any excess grease on the impeller cone, but there was a little excess silicone where the pump tunnel meets the hull on the right side. Could that really cause it to cavitate that bad?

  4. #4
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Maybe maybe not, Its just 4 bolts to pull the intake grate and check it out.It definetly isnt helping.

  5. #5

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451

    Exclamation

    Quote Originally Posted by mooneyb91084 View Post
    had the ski out for the 3rd time today, 4 hrs and countin....anywho i got under it and took a look see after i was done riding. I didnt see any excess grease on the impeller cone, but there was a little excess silicone where the pump tunnel meets the hull on the right side. Could that really cause it to cavitate that bad?
    You could also have a gap you can`t see without removing the ride plate.
    Go to R-Rated and buy the pump seal kit.
    I did. It should be here tomorrow. I`ll post my results when I get it installed and tested.
    This ski cavitates from the hole big time.

  6. #6

    Join Date
    May 2007
    Location
    Highland Village, TX
    Posts
    9

    250 Cavitation

    I have a brand new 250 with what I think may be similar issues to what others have expressed. On the hole shot, WOT, it starts to move, but then hesitates, then grabs, then hesitates, then grabs again. I'm not a mechanic (in the least) but it sounds like a similar issue.

    I took it back to the dealer. They tried adjusting the supercharger belt... no difference. Then I showed them this thread and they re-sealed the pump as stated, but still no difference. They have been very accomodating and trying to assist, but the problem, as of now, is still unresolved. They are going to go back to Kawasaki for input.

    Any ideas or people I could contact?

    Thanks in advance,

    Bob

  7. #7

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451

    Wink

    Quote Originally Posted by BRuss View Post
    I have a brand new 250 with what I think may be similar issues to what others have expressed. On the hole shot, WOT, it starts to move, but then hesitates, then grabs, then hesitates, then grabs again. I'm not a mechanic (in the least) but it sounds like a similar issue.

    I took it back to the dealer. They tried adjusting the supercharger belt... no difference. Then I showed them this thread and they re-sealed the pump as stated, but still no difference. They have been very accomodating and trying to assist, but the problem, as of now, is still unresolved. They are going to go back to Kawasaki for input.

    Any ideas or people I could contact?

    Thanks in advance,

    Bob
    Contact R-Rated for a pump seal kit.....It fixed mine 100%%%%%%%%
    Best $89.00 bucks I have spent in a while.
    1-732-606-1163 Rudy.

  8. #8

    Join Date
    Mar 2007
    Location
    Ankeny, Iowa
    Posts
    22
    How hard to install is their seal kit, any special tools needed ??

  9. #9

    Join Date
    Aug 2005
    Location
    Salinas CA
    Posts
    451

    Wink

    Quote Originally Posted by terminator View Post
    How hard to install is their seal kit, any special tools needed ??
    Pull the intake grate. Clean off all the silicone, install the rubber seal kit and reseal the grate per the instructions....Wha-la...Your done. Your hole-shot is 100% and your pump will be more efficient.
    You might even gain some MPH. Mine went from 67.0 flat to 69.5 with the pump kit, wedge and secondary muffler delete.

  10. #10

    Join Date
    Mar 2007
    Location
    Ankeny, Iowa
    Posts
    22
    Thanks for the info, I'll have to give Rudy a call....

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Prop boot and cavitation
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-28-2011, 08:09 PM
  2. Cavitation help
    By mattpm07 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 05-05-2006, 01:34 PM
  3. R&D Anti Cavitation Cone
    By Kinchyle in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-02-2006, 10:46 AM
  4. Cavitation issue: worried
    By BDNJ in forum 4-Tec Performance
    Replies: 62
    Last Post: 09-13-2005, 08:21 AM
  5. Post on cavitation
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-04-2005, 10:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •