Results 1 to 9 of 9
  1. #1
    THEE 6'5" 235pd rough rider doc212121's Avatar
    Join Date
    May 2007
    Location
    MI
    Posts
    396

    04 RXP turns 5700RPMS today, help needed?

    Put some new gas in it this spring, just took it out for a quick run, about half old gas, half new gas, turned 5700 RPMS, and sounds like a diesel running. New plugs needed? WHat type, what oil also, and how do you change the oil? Im a newb to it.
    Thanks


  2. #2
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Lets eliminate bad plugs by putting in some new ones.

    Check the pump, and make sure that you do not have debris in the pump area.

    Next, do you hear the supercharger whining when you rev it?

    If you do not, take the intake for the supercharger off (The front hose on the supercharger), and try to spin the impeller. If you can spin it easily, you have almost certainly grenaded the washers into your engine.

    You are at the RPM level where motors tend to run when the SC washers grenaded......

    check those things and get back to us........

  3. #3
    THEE 6'5" 235pd rough rider doc212121's Avatar
    Join Date
    May 2007
    Location
    MI
    Posts
    396
    Great then I just got scammed on this machine if its the washers............

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    When the washers go it typically revs to 64-6500 but it runs well. More than likely the plugs just need to be changed.
    BUT, do as Jeff says and check the S/C impeller by pulling off the hose.
    And if the washers are good, and the plugs take care of the issue, order metal washers for it right away...dont gamble

  5. #5
    THEE 6'5" 235pd rough rider doc212121's Avatar
    Join Date
    May 2007
    Location
    MI
    Posts
    396
    Got ya, pulled the plugs and they look OLD, even had some rust colring on the white top of the plug, I hope its just them, what gap do they need to be at? Do they need to be prepped before installed?

  6. #6
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    I had a simular problem, bad fuel. Change plugs, Drain as much of the old fuel as you can and refill with fresh. Remove filler neck from tank and siphon out. Take the hose off the supercharger housing and see if the sc wheel has tension on it. If it spins then washers are gone.

  7. #7
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Quote Originally Posted by doc212121 View Post
    Got ya, pulled the plugs and they look OLD, even had some rust colring on the white top of the plug, I hope its just them, what gap do they need to be at? Do they need to be prepped before installed?
    The rust coloring is actually normal. .030 on the gap. Pull the intake hose and check the S/C too

  8. #8
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Location
    Southern California
    Posts
    1,735
    It's the plugs. Replace them and ride hard!

  9. #9
    THEE 6'5" 235pd rough rider doc212121's Avatar
    Join Date
    May 2007
    Location
    MI
    Posts
    396
    Got the plugs, gapped them at .30 and Ill be home at 7 tonight to try her out!
    Thanks guys
    Andy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 RXP Rotax Racing ECU help - 8000rpm redline? what gives?
    By boostaholic in forum 4-Tec Performance
    Replies: 21
    Last Post: 06-04-2016, 07:39 PM
  2. 04 RXP Sensor light Code P1517 Need Help/Advice on Removal Please Read
    By davidrxp in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 12-03-2013, 08:22 PM
  3. 04 rxp sputtering and coughing HELP!
    By Jetskirxp in forum 4-Tec Performance
    Replies: 18
    Last Post: 07-03-2011, 08:39 PM
  4. stock 04 RXP low RPM's help
    By sylvan in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-18-2009, 03:29 PM
  5. 04 RXP Turning 7700 RPM?
    By snowrunner in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-14-2007, 12:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •