Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594

    leaking anit freeze

    my ski was winterized by dealer. I hooked up battery today and went to start it up. it only cranked for maybe 10 seconds then I realized I didnt hook up flush kit. So I turned it off and left it go. Later today I unhooked ski from my truck and when I tilted ski up and movedit I noticed the anti freeze. Haven't had time to look inside yet .

    Anyone know why this is leaking or from where? I think it spilled out from back end , when I tilted ski up


  2. #2
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Hummer:

    It is probably the antifreeze coming out of your exhaust. The dealer winterized it and they put some antifreeze into the exhaust to make sure nothing freezes from water pooling.

    Was the antifreeze a red color?

    If it was it was certainly used in the exhaust as your ski uses the green variety.

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    I too had anti freeze in the bottom of my hull. None was put in the exhaust though.

  4. #4

    Join Date
    May 2005
    Location
    Louisville KY.
    Posts
    156
    They probably ran antifreeze through the intercooler. When you started it up it blew out the exhaust and was sitting on the ride plate. Then when you tilted it back it drained off the ride plate. I would not worry about it just keep a eye on the coolant bottle and if you see it getting low then start digging deeper into it.

  5. #5
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594
    Thanks for the help, I hope its from exhaust because it is sitting on ride plate. I just checked and there is none in the hull and the coolant bottle is ok also.
    The anti freeze is green.

  6. #6
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    What color is it ? marine anti freeze is ussualy pink or ppurple

  7. #7
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    If you're asking me it was bluish green.

    If you're asking him he said it was green.

  8. #8
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Now that you mention it, I had antifreeze in the hull as well when I first started it up.

    I am trying to diagnose a leak, and had the cowling off, so the bottle was upside down while trailering it to the lake, so I thought a bit leaked out from having the bottle upside down, and did not give it much thought at the time. When I started the engine I noticed the green antifreeze.

    Those of you who saw antifreeze, does it get real cold where you are in the winter? I wonder if there is a systemic problem that is starting to arise. I saw just a little bit of antifreeze right where the hose pickup comes out of the ride plate........Hmmmmmmmmm

    I just got my borescope off ebay today, and I plan on going over the ski with a fine tooth comb to find the leak.

  9. #9
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594
    it was definately green. just like what you see out of a car. I will call Derrick tomorrow at surf and turf to ask him, since he winterized it.

  10. #10
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Quote Originally Posted by Jeff C View Post
    Those of you who saw antifreeze, does it get real cold where you are in the winter?
    ohhhh yeah. wayy below 0°F

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Leaking A-freeze on the ride plate
    By ou812 in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-04-2010, 09:08 PM
  2. 04 RXP - Leak into Hull thru VTS
    By joeg in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-01-2005, 02:21 AM
  3. Rotax Racing IC - How to find leaks?
    By Jarrett in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-05-2005, 12:16 AM
  4. Does your RXP leak?
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 15
    Last Post: 05-31-2005, 11:31 AM
  5. I might have a oil leak in the RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-02-2005, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •