Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: RXT overheating

  1. #1
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311

    RXT overheating

    went out yesterday and my RXT was overheating badly,

    it was over heating at WOT before so I took my J pipe out and made the 3 holes larger and I used 2 clamps instead of the 3 as I thought one of the clamps was resticking the holes,

    I removed my pump this morning to check the pump and water reducer thinking I may have left it out or it was clogged as there was alot of trash in the water but it was clear I was missing on washer on the 2 baling tubes, anyway it did not start overheating at first then after about 30 minutes it started and it got worse I could not run it over 3000-3500 without it going off

    what do you guys think? is there a adapter I can use on the pump to flush the system I plan on removing the hose at the pump making a adapter then removing the exit hose on the intercooler and check for water flow, if water flows though the intercooler what can I do next?


  2. #2
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    check your coolant level? or are you talking about the exhaust temp only?

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Is it a "High Temp" alarm? If so its exhaust related. Are you running a water strainer before your intercooler?

    Im willing to bet you have a clogged intercooler.... even if water flows thru it you are not getting enough water flow at high speed.

    Alarm coming on about 7800 R's?

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    By the way, this is the best way i have found to clean an intercooler out. I do this proceedure at least twice a year

    http://www.greenhulk.net/forums/showthread.php?t=15167

  5. #5
    Jerry do you flush your intercooler twice a year even while running a water strainer?

  6. #6
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    the last 3 time I had it out it would go off at 8100 then yesterday it first went off at 8000 and got worse from there I could not run above 3500 without it going off it was a lone ride back at 18 MPH

    I am going to clean the intercooler tonight then install the stainer, the hose on top of the J pipe was hot and did not have much water running threw it I rmoved that hose while in the water started it up and very liittle water was coming out of the top of the J pipe

  7. #7
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650

    Wink

    It might have been lonely, but you werent alone, we were going to make shhr you got back,lol.To bad I didnt have a spare chic to keep you company on that ride back,

  8. #8
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    I lost some speed yesterday, so I ordered all the o rings for my inter cooler, going to take it apart tomorrow night and see what goodies may be in there, It was nasty water out there yesterday, I got the strainer from here, but the lines are different size then the SeaDoo, and I have been lazy and not tried to find the right sized nipples, anybody know where those can be obtained.

  9. #9
    RXTRIDER Chulito07's Avatar
    Join Date
    May 2007
    Location
    Kissimmee, FL
    Posts
    6
    Sounds Like a problem I had before. Check the RIDE Plate as I cracked mine and the coolant was leeaking from there. I had to wait like 2 months to get another one. This was last Nov 2006 and the part was on back order. Check your coolant bottle if it drains it out really quick I am almost sure that what it is.

  10. #10
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    Yea Harry you could have let me borrow the one that was riding with you

    my coolent level has always been ok my problem is on the exhaust side

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 07-07-2016, 10:23 AM
  2. 2012 RXT-X grounded and overheated - what should I check?
    By Incorrigible in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-02-2012, 09:28 AM
  3. New to 4-Tec..overheating issue RXT '05
    By SideFX in forum 4-Tec Performance
    Replies: 27
    Last Post: 07-11-2010, 07:32 PM
  4. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  5. RXT v ?
    By diceclay in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-02-2005, 02:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •