Results 1 to 7 of 7
  1. #1

    Join Date
    May 2007
    Location
    Peoria,IL
    Posts
    30

    Couple of questions?

    I have recently bought a 2004 RXP with 13 hours on it. I have already order the Jerry's washers for the supercharger and I have not even riden it yet so I think i have that problem resolved ( if i didnt have bad luck i wouldn't have any). I have checked the s/c charger and I can not spin it by hand after removing the inlet hose. My questions are:

    1. the shop manual talks about some special grease that must be put on the s/c shaft prior to installation of the needle bearings. Is this a requirement because it is not listed in the instructions that Riva published and that I accessed through this site.

    2. After installing the washers is there any need to readjust after a short time?

    3. When I start the ski up on out of the water there is a rattling noise from the back of the ski. It will quiet down some when I turn the hose on when flushing the ski. It also seems to go away with higher rpm. I have heard that this is normal but just want to make sure.

    The ski is completely stock if that helps.

    Sorry for the long post and thanks for any help.

    Sean


  2. #2
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Quote Originally Posted by SeanJ View Post
    I have recently bought a 2004 RXP with 13 hours on it. I have already order the Jerry's washers for the supercharger and I have not even riden it yet so I think i have that problem resolved ( if i didnt have bad luck i wouldn't have any). I have checked the s/c charger and I can not spin it by hand after removing the inlet hose. My questions are:

    1. the shop manual talks about some special grease that must be put on the s/c shaft prior to installation of the needle bearings. Is this a requirement because it is not listed in the instructions that Riva published and that I accessed through this site.

    2. After installing the washers is there any need to readjust after a short time?

    3. When I start the ski up on out of the water there is a rattling noise from the back of the ski. It will quiet down some when I turn the hose on when flushing the ski. It also seems to go away with higher rpm. I have heard that this is normal but just want to make sure.

    The ski is completely stock if that helps.

    Sorry for the long post and thanks for any help.

    Sean
    1.You can put anti seize 3 bucks at pep boys.
    2. No you dont have to worry about it and if it does start slipping its an easy fix with a shim but chances are that u wont need to shim it for at least 50 hours
    3.The noise is normal

    Smart move not riding it untill u get the ceramics out and welcome to the forum
    Last edited by ReDevilRXP; 05-11-2007 at 09:43 AM.

  3. #3
    BMW FTW Yellow04RXP's Avatar
    Join Date
    Apr 2007
    Location
    Monroe, La
    Posts
    342
    the noise is normal but i have no clue what causes it

  4. #4
    Dr Len's Avatar
    Join Date
    Jan 2006
    Location
    New Jersey Attitude Capital of the World
    Posts
    1,170
    The grease they are talking about is isoflex. When installing the washers. I always put a thin coat of this grease on the washers.So the washers aren't dry at start up. The oil will shortly wash the grease away.Here's the catch. when you check the slip it's a little off. Because of the grease. Its right at the end of the slip spec.After the grease washes away. Im sure the slip is just fine. ( Isoflex Grease is available from Parker Yamaha )

  5. #5
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    I just oil the washers when installing and torqueing...no special grease needed.

  6. #6

    Join Date
    May 2007
    Location
    Peoria,IL
    Posts
    30
    Thanks for all the help. Jus waiting on parts so I can get everything switched out and go ride.

  7. #7
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Location
    Southern California
    Posts
    1,735
    The niose you hear when the ski is fired up out of the water is normal. Every Sea-Doo from 1988 has done it. There is play in the driveshaft to the pump housing. The reason you don't hear it in the water is because the pump is loaded by the water moving through it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. couple of questions
    By 05blastsrt4 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 07-15-2007, 11:07 AM
  2. New '07 150 SCIC owner, couple of questions.
    By Armand28 in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 05-26-2007, 04:40 AM
  3. Newbie saying hi, and a couple of questions.
    By aussie rxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-06-2007, 01:02 AM
  4. Couple of questions please help...
    By OzVirage in forum Polaris Open Discussion
    Replies: 6
    Last Post: 02-12-2007, 08:39 PM
  5. Replies: 171
    Last Post: 11-04-2006, 06:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •