Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776

    RR SC Impeller install question

    I'm putting together a 2005 SC with a Rotax impeller and noticed that the hub of the RR is about .100 thicker than the stock impeller so the nut doesn't engage nearly as many threads. Is the washer supposed to be left out, was there supposed to be a different nut, or use the the stock nut and washer?


  2. #2
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    Maybe I should ask what nut and washer did you use when you installed your impeller?

  3. #3
    mxl16's Avatar
    Join Date
    May 2005
    Location
    Central NJ
    Posts
    1,590
    i used the stock nut with no washer.

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Just took mine apart last night. Stock acorn nut and washer with RR wheel(GH installed) ...... red loctite, 22 ft. lbs, and dont worry about it...

  5. #5
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by RXP Steve View Post
    Just took mine apart last night. Stock acorn nut and washer with RR wheel(GH installed) ...... red loctite, 22 ft. lbs, and dont worry about it...
    I used acorn,washer,22ft & BLUE loc-tite.
    Blue is good ...No?

  6. #6
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    I appreciate it! three different answers so far though OU812, I don't think blue loctite would be permanant enough, probably would be best to take it apart and put some red on it.

  7. #7
    mxl16's Avatar
    Join Date
    May 2005
    Location
    Central NJ
    Posts
    1,590
    Jerry put mine together and if i remember correctly there was no washer. the nut has more than enough surface area and i would rather have the extra threads.

  8. #8
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Quote Originally Posted by mxl16 View Post
    Jerry put mine together and if i remember correctly there was no washer. the nut has more than enough surface area and i would rather have the extra threads.
    Maybe 05 and 06 are different??

  9. #9
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    I have an '06 ski but plan to use the spare '05 charger that I have so my original will be unmolested should I need to re-install for some reason. I think that I have some very thin stainless washers and may use one of those if it will work, otherwise I'm going with no washer. The difference in the two impellers is .125 inch and the stock washer is .080 inch. I hate to lose 1/8" of threads! I'll compare the 05 & the 06 when I take it apart. And again, I appreciate the input.
    Last edited by GTXX; 05-12-2007 at 12:12 PM.

  10. #10
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by GTXX View Post
    I appreciate it! three different answers so far though OU812, I don't think blue loctite would be permanant enough, probably would be best to take it apart and put some red on it.
    Yup, PITA!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. rr sc impeller
    By Krazy-K in forum 4-Tec Performance
    Replies: 26
    Last Post: 11-21-2006, 08:42 PM
  2. When adding RR SC impeller and 42's
    By smc in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-29-2006, 11:42 PM
  3. RR SC Impeller/ECU results
    By 05Limited in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-02-2006, 01:36 AM
  4. for those that bought RR sc impellers
    By rotax racing in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-19-2006, 06:10 AM
  5. RR SC IMPELLER STATUS??
    By jk in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-19-2006, 12:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •