Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Help with sl780 fuel problem

    I just bought a set of polaris sl780's and one of them has a fuel problem. I have to hold the throttle wide open and spin it over for a while to get it to start, while doing this it blows gas out the top of the #1 carb and also pours gas out of the exhaust. When it sarts it does not blow as much gas out but there is still a little coming out. Any help would be appriciated.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    Hey Welcome to the Hulk. I would guess that you have a reed problem,

  3. #3
    I am taking the carbs off right now but it started raining. How can I tell if the reed is bad? Thanks

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    Inspect them look for broken or cracked peddles.

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    HI tucker, I'd also like to say WELCOME to the Green Hulk Forums.

    I like beers idea, I know that's where I'd start.

  6. #6
    I just got the reed valves off and sure enough one of the peddles was broken off. I m going to order some gaskets and a valve and see how it does. Thanks

  7. #7
    Would the bad reed explain the gas in the exhaust, and it running terrible? I also have a problem with the other ski, I took it to the lake and it ran great until it got low on gas so we went and got some gas but when we got back to the lake it would not plane out. I took it to the shop and they drained the gas out of both ski's mixed it together, added some oil, put it back in and changed the plugs. We took it back to the lake and it ran fine until it got low on gas again, my brother unknowingly took it back to the same store and got gas when he got back it ran like crap. I brought them home to check it out while doing so I decided to remove the plug wiires one at a time and noticed the middle cylinder was not firing right so I decided to check the compression the front and back had 130psi and the middle had 50psi. I went ahead and drained the bad gas, changed the plugs and took it back to try it out, it ran as well as it did before the day before. Today while I was working on the other one I decided to run it for a minute and see how it ran, it sounds as if it would be bogged down if I took it out today. Is there anyway the cylinder could have good compression at some time and not at others because when it is running right it will out run my ski boat, could it do that on two cylinders with a 6'4 270# man riding it. Thanks for the help.

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    Quote Originally Posted by jtucker84 View Post
    Would the bad reed explain the gas in the exhaust, Yes and it running terrible? Yes I also have a problem with the other ski, I took it to the lake and it ran great until it got low on gas so we went and got some gas but when we got back to the lake it would not plane out. I took it to the shop and they drained the gas out of both ski's mixed it together, added some oil, put it back in and changed the plugs. We took it back to the lake and it ran fine until it got low on gas again, my brother unknowingly took it back to the same store and got gas when he got back it ran like crap. I brought them home to check it out while doing so I decided to remove the plug wiires one at a time and noticed the middle cylinder was not firing right so I decided to check the compression the front and back had 130psi and the middle had 50psi.Not good I went ahead and drained the bad gas, changed the plugs and took it back to try it out, it ran as well as it did before the day before. Today while I was working on the other one I decided to run it for a minute and see how it ran, it sounds as if it would be bogged down if I took it out today. Is there anyway the cylinder could have good compression at some time and not at others Not likely check compressing again because when it is running right it will out run my ski boat, could it do that on two cylinders with a 6'4 270# man riding it. Thanks for the help.
    You should start two threads one for each ski. that way we know whats up with each.

  9. #9
    I replaced the reed valve, started it up and it sounded good so I took it back to the lake but when I got there it was hard to start I had to spin it over with the throttle wide open for a little bit before it would start. When it finally started it seemed to be bogged down but I kept playing with the choke and it would run good plane out and hit about 6400 rpms but only for a short period then bogg down again. Any idea on what to do next? Thanks.

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Chances are the ski may need the carbs rebuilt. It prob. sat for a while without any Stabil in the gas and varnished the insides of the carbs. The choke helping the situation, makes me think your running lean and the choke richens up the mixture. You need to fix that before you burn down a piston or worse.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help with 01 RX Problem
    By MPower in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-07-2008, 08:10 AM
  2. Some help with GP1200r ign problem
    By xr1million in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 06-04-2008, 03:01 PM
  3. Help with diagnosing piston problem
    By MohaveChuck in forum Polaris How To & FAQs
    Replies: 31
    Last Post: 05-30-2008, 03:10 PM
  4. help with my vx problem
    By timmy_philson in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 05-17-2008, 12:21 AM
  5. NEED HELP! with oil pressure problem!...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 55
    Last Post: 11-21-2006, 05:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •