Results 1 to 5 of 5
  1. #1

    Join Date
    Feb 2007
    Location
    Bowie, MD
    Posts
    79
    +1
    3

    Steering pulling to the left / Speedo

    (5 hours on sk ) I noticed under full throttle, my ski pulls to the left. It's hardly noticeable at slow speeds, but on long runs, I noticed that I had to constantly steer the ski to the right to make it go straight. Keeping it straight on long runs meant that the bars were uneven ( right bar down, left bar up ). Also, that damn speedo isn't acurat at all.

    When I left the water, I took the skis straight to the dealer. For 12K, this ski is going to run perfect this summer. Any little thing that is incorrect is going to get fixed by Kawasaki.

    MS


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    did you install a wedge? if you did , did you adjust the steering cable?

  3. #3

    Join Date
    Feb 2007
    Location
    Bowie, MD
    Posts
    79
    +1
    3
    No wedge installed. The ski is totally stock with no changes made.

    MS

  4. #4

    Join Date
    Feb 2007
    Location
    Bowie, MD
    Posts
    79
    +1
    3
    Dropped the ski off at the dealer to fix the alignment on the steering and the speedometer. The tech guy said he's not sure what can be done about the speedo. Hmmm....why bother putting one on at all. He also said the steering check is part of the 10 hour service.

    MS

  5. #5
    tomgtv's Avatar
    Join Date
    May 2006
    Location
    Weston Florida (Ft. Lauderdale)
    Posts
    1,744
    +1
    1

    Lower paddle wheel to fix speedo

    You just lower paddlewheel to fix speedometer reporting too slow.
    In fact I did such a good job it reports a little high versus my GPS.
    It's just a rough guide anyways........

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pulling to the Left
    By UNSANE in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-21-2011, 08:54 PM
  2. I (had) a bad pull to the left
    By Pistonwash in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 02-15-2009, 07:33 PM
  3. VTS Problem - Pulling to the Left when Trimmed up 100%
    By ImAcoustic in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-17-2008, 02:11 PM
  4. Pulling to the left after being at dealer
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 06-24-2008, 11:31 AM
  5. '06 GPR pulls to the left ?
    By steach in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 08-18-2006, 10:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •