Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    03 Aquatrax F12X where does this hose connect?

    I bought this 03 f12x turbo ski from a guy who said the dealer told him the turbo was seized and it would be $3,000 to fix, I freed it up in about a minute but they also pulled the pump out of the back because a rope was Tangled in the impeller. Now the impeller is just hitting the pump housing so I need to figure out what to do about that, pump housing is slightly scarred but the impeller looks perfect I know it has to be bent a little though because it's hitting. I have a hose running across the top of the engine and it just has a clamp and it was like that when I got it any idea where it connects? Also need to know, where does the other end of the turbo connect? I don't think the turbo hose is even here. Looks like everything else is here. The ski powers on, I cranked it over a couple seconds to see it wasn't locked up but he said it runs? Also they pulled the rubber coupler between the engine and rear shaft out, how do I get that back in there? It's gonna take a lot of research, I did find a service manual for an 05 model.

    Thanks, 5string
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20160919_185942.jpg 
Views:	15 
Size:	89.5 KB 
ID:	399472   Click image for larger version. 

Name:	20160919_185931.jpg 
Views:	15 
Size:	74.8 KB 
ID:	399473   Click image for larger version. 

Name:	20160918_183559.jpg 
Views:	16 
Size:	85.1 KB 
ID:	399474  
    Last edited by 5string; 09-21-2016 at 08:48 AM.


  2. #2
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,511
    +1
    238
    water jet stator got salt water in between stainless liner and water jet stator housing, you will have to replace, if it's a Skat 17/29 then they run a extremely close tolerance but if it's rubbing really bad the water jet stator housing will need to be replaced

  3. #3
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,511
    +1
    238
    the hose looks like crank case ventilation hose going from air box to the crankcase

  4. #4
    Well I'll pull the impeller and check it then and see what's going on. I didn't know there was a sleeve on that housing but before I spend a bunch of money I'm going to try to get the ski running, if it'll run then I'll work on fixing the housing.

    Thanks, 5string in Swansboro

  5. #5
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,511
    +1
    238
    other end of turbo needs a UNI filter or a K&N on it

  6. #6
    Maybe I could smooth out the flatspot and then use a piston hone on my drill to smooth it out a little and get it good enough to test the ski before I buy a new housing.

    5string

  7. #7
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,511
    +1
    238
    might be able to, does it lock motor up?

  8. #8
    Thanks, I was ting to find a pic of the other end of that hose but not any good ones showing where it connects. I know there is a good size flex hose that was hanging from the black cover over that area, maybe it's the battery cover but it has the tool kit in it and fire ex. In it? A hose with a clamp.Click image for larger version. 

Name:	20160918_190427.jpg 
Views:	13 
Size:	74.3 KB 
ID:	399498

  9. #9
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,511
    +1
    238
    it hooked up to intake tube from turbo to front of ski, which appears to be removed you can put a small K&N filter on that

  10. #10
    When I spin it by hand it does, the pump was out when I bought it.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. where does this hose go?
    By drooh in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 12-03-2012, 07:28 AM
  2. Macsboost IC install - Where does this hose connect?
    By loudsubz in forum Honda Performance
    Replies: 2
    Last Post: 05-06-2012, 09:29 PM
  3. where does this hose go?
    By jayohentran in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-16-2010, 12:33 PM
  4. HELP Where Does this Hose Go??
    By ppezzolla in forum 2-Stroke Performance
    Replies: 6
    Last Post: 05-17-2009, 05:30 PM
  5. where does this hose go??? pics attached
    By Tarheel in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 06-13-2008, 09:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •