Results 1 to 2 of 2
  1. #1

    clogged hose? garden hose connected and no water coming out

    I have an 03 Aquatrax F12X connected to a hose, I'm not getting any water out of the pee hole. I have seen video of these running on the hose and I have the manual showing how to flush it. What do I need to check, or where could it be clogged?

    Thanks, 5string


  2. #2
    I got it working.

    5string

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 98 gp760 no water coming out side spout
    By pwint80 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 04-29-2012, 07:44 PM
  2. pulled some mud into vx cruiser no water coming out of the top? help please
    By JoezCrown in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 09-08-2011, 08:28 PM
  3. 08 VX Deluxe - half speed, no water coming out of side exhaust port
    By Lee G in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 06-28-2011, 12:47 PM
  4. possible cause of pilot outlet no water coming out?
    By andy95'slx780 in forum Yamaha PWC Performance (4-stroke)
    Replies: 16
    Last Post: 06-17-2011, 07:43 AM
  5. FX SHO no water coming out of cooling spouts?
    By SHOBOATIN in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 04-17-2011, 01:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •