Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 40

Thread: Need Help ASAP

  1. #1
    BMW FTW Yellow04RXP's Avatar
    Join Date
    Apr 2007
    Location
    Monroe, La
    Posts
    342

    Need Help ASAP

    I am trying to pull the s/c for the 2nd time....last time I pulled it once the bolts were out it slipped out easily. This time its stuck and not budging. I have tried getting some leverage between the block and s/c and no matter what I do it is not making any progress. What do I need to do? I am trying to get it pulled tonight so I can have my RR wheel installed tomorrow


  2. #2
    Quote Originally Posted by Yellow04RXP View Post
    I am trying to pull the s/c for the 2nd time....last time I pulled it once the bolts were out it slipped out easily. This time its stuck and not budging. I have tried getting some leverage between the block and s/c and no matter what I do it is not making any progress. What do I need to do? I am trying to get it pulled tonight so I can have my RR wheel installed tomorrow
    dumb question: are the correct bolts out?...PR...
    can you rotate SC any?...

  3. #3
    BMW FTW Yellow04RXP's Avatar
    Join Date
    Apr 2007
    Location
    Monroe, La
    Posts
    342
    Quote Originally Posted by Pale Rider View Post
    dumb question: are the correct bolts out?...PR...
    can you rotate SC any?...
    yup I have rotation but not forward movement

  4. #4
    Quote Originally Posted by Yellow04RXP View Post
    yup I have rotation but not forward movement
    now your just upgrading right? no SC explosion?
    something doesn`t make sense ...you put grease on the sc collar last time it was out?, maybe you just have to keep rotating it a bit and work it out...

  5. #5
    BMW FTW Yellow04RXP's Avatar
    Join Date
    Apr 2007
    Location
    Monroe, La
    Posts
    342
    Quote Originally Posted by Pale Rider View Post
    now your just upgrading right? no SC explosion?
    something doesn`t make sense ...you put grease on the sc collar last time it was out?, maybe you just have to keep rotating it a bit and work it out...
    yes it had grease on it and i have been rotating it back and forth for about an hour now and still no luck

  6. #6
    Quote Originally Posted by Yellow04RXP View Post
    yes it had grease on it and i have been rotating it back and forth for about an hour now and still no luck
    wow, you have everything pushed back, waterbox and all, I don`t know what to say

  7. #7
    BMW FTW Yellow04RXP's Avatar
    Join Date
    Apr 2007
    Location
    Monroe, La
    Posts
    342
    Quote Originally Posted by Pale Rider View Post
    wow, you have everything pushed back, waterbox and all, I don`t know what to say
    yup everything is out of the way.....like i said it came out easy the first time now it is being a Bitch

  8. #8
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594
    I took mine out for first time yeterday, it was stuck. I grabbed it by the long neck where the tube connects and pulled up and down to rotate the whole super charger and it freed up. double check to make sure the 3 correct bolts are out

  9. #9
    BMW FTW Yellow04RXP's Avatar
    Join Date
    Apr 2007
    Location
    Monroe, La
    Posts
    342
    yeah all the bolts are out, it freely rotates but it will not dislodge free from the internal gears

  10. #10
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    try bumping it with a rubber hammer, if that doesn't work try putting a socket on the impeller nut and moving it a touch each way.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help ASAP!
    By 06viperrxp in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-11-2007, 11:09 AM
  2. Need help ASAP
    By SeanJ in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-29-2007, 06:06 PM
  3. Need help ASAP pro cdi wiring....
    By Rodneyae in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-05-2007, 08:58 PM
  4. need help asap!!! please
    By nonvtecdaturbo in forum Polaris Open Discussion
    Replies: 23
    Last Post: 12-12-2006, 08:11 AM
  5. Need help ASAP!
    By r33pwrd in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 07-05-2006, 07:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •