Page 12 of 12 FirstFirst ... 2 10 11 12
Results 111 to 116 of 116
  1. #111
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,839
    +1
    19
    Quote Originally Posted by xlint89 View Post
    WSM or SBT are prob made by the same place, just put different name on it.

    I wonder if you're sucking a little water into that CEN cyl? Normally if that's the case, the piston is completely clean, but your lack of wash seems odd.

    Inspect your O ring seal real good and check for head warpage.
    That would seem to be possible. They looked okay when I had the head off and glanced them over real quickly but I'll check them again carefully. Would the plug also be steam cleaned white if I was leaking? The plug is sort of dark brown.

  2. #112
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,839
    +1
    19
    So the ski is acting a bit strange yesterday. I put in the 10.5/16.5 prop and I must say I love how hard it hits off the line. It is like it is almost on the brink of cavitating but it just hits so hard. I didn't get the rpms I was expecting with it....maybe pulling only 7800 or so. One thing that was strange, after going around the buoys a few times, the clamp for the header to pipe on the PTO cylinder was so hot that water was sizzling off it. I opened up the PTO screw half a turn because that obviously shouldn't happen and I ended up hitting 7840 rpm.....seems that cylinder is running lean. I opened up all the screws and now I am hitting 7850 or so. I am beginning to think that the fuel return jet is too big....I might try a #60 or #70 to see how it reacts.

    I'm getting more rpm on a slight right hand turn and also when I let off the throttle some...both indicators of running rich but I'm still not getting he revs out of her and that super hot header pipe has got me worried.

  3. #113
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,839
    +1
    19
    So after not giving up, I found a replacement part for the steering cable hull fitting. It looks like Yamahas uses the same setup as our Polaris skis so I will be buying a new fitting set instead of a whole new cable since my cable is still in great condition. I just ordered this and will be the guinea pig to be sure it fits.

    Part number is EU0-67267-10-00

    I also got a #60 jet for the return restrictor. I'll be putting this in the ski to see if the ski was just running too lean with that hot pipe.
    Last edited by hyoctane23; 04-21-2017 at 11:10 AM. Reason: Corrected part number

  4. #114
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    35,062
    +1
    1,034
    Post the Polaris part number so people can find this info via search, in the future.

    Also post up photos of new and old, and after installation.

    Thanks.

  5. #115
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,839
    +1
    19
    Unfortunately there is not a Polaris part number to this fitting as you can't buy it separately. That is why most people are probabby forced to buy a whole new cable when the actual cable itself probably is still good.

    Here is a stock picture of the Yamaha part. I'll for sure post up pictures when I try this new one out.

    Correction to the part number....it is
    EU0-67267-10-00
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Fitting 2.jpg 
Views:	1 
Size:	41.8 KB 
ID:	411114  
    Last edited by hyoctane23; 04-21-2017 at 11:11 AM. Reason: Corrected part number

  6. #116
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,839
    +1
    19
    I also forgot to mention that I installed my Hot Seat ride plate last night. I sanded out all the gouges, have the trailing edge a good sharp edge, chemically cleaned and Alodined the plate. Hope she handles even better now!

    Click image for larger version. 

Name:	20170421_073757.jpg 
Views:	13 
Size:	40.8 KB 
ID:	411113


Page 12 of 12 FirstFirst ... 2 10 11 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Thoughts on a Pro 785
    By slx1200 in forum Polaris Open Discussion
    Replies: 22
    Last Post: 02-10-2017, 08:31 PM
  2. break in on my pro 785 and only like half burning on the center cyl
    By wayneb2510 in forum Polaris PWC Performance
    Replies: 69
    Last Post: 07-09-2013, 08:32 AM
  3. no fire on the center cyl on the new 785 pro
    By wayneb2510 in forum Polaris Projects
    Replies: 1
    Last Post: 06-26-2013, 09:24 PM
  4. fiberglass repair on a pro 785
    By ujustlost in forum Polaris Open Discussion
    Replies: 20
    Last Post: 03-12-2010, 07:37 PM
  5. Is the pro 785 a domestic?
    By ZMANN in forum Polaris PWC Performance
    Replies: 3
    Last Post: 01-13-2007, 03:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •