Results 1 to 4 of 4
  1. #1

    2000 GP760 Charging question

    I'm new to this site but not new to ski problems. I've blown up and rebuilt several gp1220r's. My GP760 display went dead after I charged the ski the other day. The ski runs fine except there is no display. The voltage is the same whether it's running or off. It reads right at 12 volts. I did a check on the two green wires from the rectifier and it read 15.6 mohms. Any ideas would help. Thanks.


  2. #2
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Quote Originally Posted by kinderguard View Post
    I'm new to this site but not new to ski problems. I've blown up and rebuilt several gp1220r's. My GP760 display went dead after I charged the ski the other day. The ski runs fine except there is no display. The voltage is the same whether it's running or off. It reads right at 12 volts. I did a check on the two green wires from the rectifier and it read 15.6 mohms. Any ideas would help. Thanks.
    You need a new stator.

  3. #3
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    I learned this one the hard way....

    1999 XL760 guage wasnt working so I bought a new guage,still didint work,read the repair manual & it said the guage needed AC voltage to operate (power from the stator before the voltage reg) checked charging output,none,replace stator,charging system works & guage works as well.

  4. #4
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Man nothing like experience great post. The way things are supposed to work

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How much 4 a 2000 gp760
    By kndtenn in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 08-27-2007, 03:03 PM
  2. 2000 slx fuel question
    By SGT BLOODYSTUMP in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-15-2007, 03:20 AM
  3. 2000 Genesis FFI questions
    By havasufun in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-10-2007, 06:13 PM
  4. Battery and Charging Question
    By tomgtv in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 01-20-2007, 07:31 PM
  5. Charging question 951cc GSX Ltd
    By tomgtv in forum 2-Stroke Performance
    Replies: 7
    Last Post: 01-14-2007, 09:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •