Results 1 to 8 of 8
  1. #1

    UMI Steering system

    I started to put my new steering on today, the system looks great but there are a couple of issues i see. When we put the steering cable in the new clamps and attached it to the new umi stem i had to really push the cable back quite a ways. After we hooked it up i tried turning the stem just to check out the movement and it doesnt bind, it has full motion but the cable sounds rough and towards the back of the machine you can see the cable has a hard s curve in it. Does anybody know if this is right?


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,073
    +1
    791
    The best way is to pull the extra cable is to pull it up above the intake manifold as to make the bend go up up over the ecu and intake manifold and back down into the hull. I have had mine this way for over a year. No issue's.

    ..

  3. #3
    so I'm not the only one that has this problem. ill give what you said a shot and post my results.

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    play with it... it'll work

    that UMI is not designed for the RXP... it's from an older application and just happens to "kinda" fit..

    i called austin (water4fire) when i was installing mine, and i was like wtf dude!! this is not going to work!! lol

    it'll loosen up... the steering cable needs to relearn the new position and kinda break in

  5. #5
    O thank you for the advice. I was mad last night when I couldn't figure this thing out. Riva told me it bolts right in and it does but that cable boggled me.

  6. #6

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    For $650, you would think it would fit perfect.

    BTW, does it include a "mode" and "set" button?

    Mike

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    no mode and set buton... u gotta make your own provisions...

    for 06+ skis, the UMI is a good setup since there's no extra buttons.

    i can honestly say, now that i have my UMI totally finished and setup the way i like, it's the best item i've ever bought for my ski... i love it

  8. #8
    Ya, i have it on my 98 gsx ltd and absolutly love it. This was kinda a pain but i did what water4fire said to do with the cable and seems to be a little smoother. Ill run it like that and just keep an eye on it, thank you guys for all the real world advice, because they couldnt help me on the tech line. Anthony

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. raider umi steering system
    By big raider in forum Yamaha Classifieds
    Replies: 0
    Last Post: 09-01-2008, 07:57 PM
  2. WTB GPR UMI steering system
    By OCFZR in forum Yamaha Classifieds
    Replies: 0
    Last Post: 08-21-2008, 08:50 PM
  3. WTB UMI Steering System Kaw Ultra 150
    By Kawi_Mon69 in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 08-20-2008, 06:49 PM
  4. UMI Steering Systems
    By nrgy in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-19-2006, 10:38 AM
  5. I received my UMI steering system today
    By Green Hulk in forum 4-Tec Performance
    Replies: 23
    Last Post: 10-23-2005, 02:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •