Results 1 to 4 of 4

Thread: Bad 750 bendex?

  1. #1
    thesepaperwings's Avatar
    Join Date
    May 2007
    Location
    South East Kansas
    Posts
    1,283
    +1
    1

    Bad 750 bendex?

    I push start and I just hear the starter buzzing. The starter is new so thats not it. Could it be anything but the bendex, and how much work is that to switch out? Also, if it is the bendex then who has one for sale?? Any takers??


  2. #2
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Location
    Roanoke, Va
    Posts
    3,083
    See if the impeller shaft turns freely. Could be and engine issue. Also check for corrosion on the battery terminals and where the ground cable connects to the block.

  3. #3
    thesepaperwings's Avatar
    Join Date
    May 2007
    Location
    South East Kansas
    Posts
    1,283
    +1
    1
    I can turn the shaft by hand and the batt is freshly charged and has good connections. I tried turning the shaft in different position thinking maybe the flywheel was missing teeth but I just get the same spinning of the starter.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Most likely the bendix sticking. Not too bad to replace in the hull. Make sure you reinstall the thrust washer onto the bendix. Hardest part of it is not dropping the gas tank bolts into the hull when reinstalling. Check on Ebay for one.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 06-27-2011, 11:08 PM
  2. 94 sl 750 - bad stator?
    By vmdano in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 07-02-2010, 06:39 PM
  3. How bad I want a sl-750 or sl-650...
    By TreyGiles in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-12-2010, 11:09 AM
  4. SL 750 Possible Bad Piston...Need help...
    By bigbadb in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 02-11-2009, 09:00 AM
  5. slt 750 bad cylinder
    By 1stpolaris in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-31-2007, 02:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •