Results 1 to 7 of 7
  1. #1
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809

    Virage bilge pump issues

    I noticed a while back that my bilge pump wasn't working, so I finally tore into it. The pump is locked up tight and the motor tests "open", so it's burnt out. As soon as I plugged a new one in, it started running. Traced the wiring and found out that the orange wire on the voltage regulator is always hot, when it should only be hot when the motor is running (I think). I don't doubt the regulator's toast and will need to be replaced. Anybody have a service manual for a Virage with the info for testing it? I see the regulator is specific to the Virage, as it only has one start/stop button. The 2000 part subs to the 01-03 part, so I'm sure it was updated. Thanks. $130 for that part, BTW!


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    The voltage regulator is the one that brings the 12 volts to the bilge and it should only operate when the engine is running BUT I'd check the momentary bilge pump button and see if it's sticking or bad as it will by-pass the voltage regulator and run the bilge. The momentary switch picks up it's power source from the red/purple which is always live.

    I guess I'm saying disconnect the momentary switch and see if the bilge shuts down. LOL

  3. #3
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    Thanks for the info Al...I did already take the switch out of the loop...I was hoping that the switch was stuck on, LOL. When I disconnect the orange wire that goes from the regulator to the terminal board, its always hot at the regulator side. I'm guessing that since it controls the bilge pump, it should only be hot when the ski is running?

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    You have it exactly right. One LR505 for the dumpster.

  5. #5
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,134
    +1
    1,050
    Darn LR505 will get ya everytime. Got to run.... late for work, but this is what I found on the quick.


    .
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	picture336.jpg 
Views:	115 
Size:	106.4 KB 
ID:	25139  

  6. #6
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    Well, I tried to be a cheap skate and unhook the orange wire and only run the bilge pump manually...now the regulator completely crapped out and is running the system voltage at 15+ volts...LR 505 ordered for $130.

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    The good news is you needed one anyway.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Virage Bilge Pump Issue
    By capt_ben in forum Polaris Tech Tips and Info
    Replies: 10
    Last Post: 03-03-2014, 11:30 AM
  2. bilge pump issue, fx sho
    By bkweld in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 08-13-2012, 04:23 PM
  3. 2001 Virage bilge pump????
    By willis700 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-24-2011, 12:05 AM
  4. 2001 Virage bilge pump,is it sup
    By willis700 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 06-23-2011, 01:46 AM
  5. 2002 Virage Bilge pump wont stop?!!?!?
    By lynxer in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-27-2010, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •