Results 1 to 4 of 4
  1. #1
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5

    2 questions..1) intake grate, 2) water problem in carb??

    ((Relating to 1994 XP))

    Two different questions here and will start with the toughest:
    Put put put...Thought I might have had condensation in fuel tank, so cleaned tank bone dry, vacuumed bottom out and replaced with new. Cleaned water separator also. New plugs as well. However it still puts at about 2k rpm and gutless. (bag over head big time)
    When I siphoned out the fuel, I saw three smartie sized drops pass through the clear line I used. Is there a chance that water is trapped somewhere else, like in the float bowls of carb? What to do...what to do...

    2) Intake grates, so many choices but how do you get the right one without trying them all? I have looked at the various designs and wonder if there is someone with the experience here that might offer some recommendations. We do ocean water and some waves at times, and have experienced some cavitation on sharp turns.

    Any advice appreciated.

    Many thanks.
    Peter


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    The carbs are not like conventional motorcycle carbs...in that they don't have a float bowl. But they do have an internal filter screen in each carb that you need to clean. This is most likely your culprit. While you have them apart spray carb cleaner though all orifices.

    Here is the link for the carbs...
    http://www.mikuni.com/pdf/sbn_manual.pdf

    Worx has proven to be the best grate on X-4's

    Happy wrenching!

  3. #3
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5
    I was also informed that it might be time to R&R the fuel lines so ready to do that as well. Thanks for the tips, muchly appreciated!

    Cheers
    Peter

  4. #4
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5

    fixed the problem

    So after all, Chester stopped by today and checked things out and diagnosed it as an electrical problem. A plug wire was loose and corroded from the boot. DoH
    Went ahead and replaced the fuel filters and cleaned everything up. (Thanks Jeff) Now back to the rodeo!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 GTX 4-tec Supercharged questions about intake grate
    By whiskerfox in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-26-2016, 11:42 AM
  2. Question about intake grate. instal.
    By Alexslow1k in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 02-16-2015, 05:20 PM
  3. Question about intake grate
    By naplesrxp in forum 4-Tec Performance
    Replies: 16
    Last Post: 02-09-2014, 01:38 AM
  4. question on intake grate
    By wavehummer in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-08-2007, 05:28 PM
  5. FX ride plate & intake grate testing results are in finally.
    By Dirty Sanchez in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 06-06-2007, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •