Results 1 to 5 of 5
  1. #1

    99 GTI running poorly

    A friend of mine has this ski and it seems to idle fine, but once you give it gas it sounds like it's not getting fuel or enough fuel. He says the RPM will go up but then suddenly bottom out. I'm not very educated in the 2 stroke platform, but I want to help him if I can. Any ideas?

    Thanks.


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Filter screens in carbs are clogged.

  3. #3
    There's only one carb. Where in the carb are they located and what do I do with them, clean or replace them?

  4. #4
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    Quote Originally Posted by 96XPSS View Post
    Filter screens in carbs are clogged.
    RQ, you should write a "how to" on this for this section.

    -this will be the answer to 80% of the questions this spring(rectifier going bad, VTS module, loose fuel float and bad ground another 19%).

    Thanx for your help,
    Erin

  5. #5
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by RXPkid View Post
    There's only one carb. Where in the carb are they located and what do I do with them, clean or replace them?
    Just clean it...here's a link to the carb manual. The carb disassembles and cleans with no new replacement seals required. Spray carb cleaner in all jets and orifices while you have it apart.

    http://www.mikuni.com/pdf/sbn_manual.pdf
    Last edited by 96XPSS; 05-24-2007 at 07:32 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 slx 1050 Fuel leaking out of rear carb running poorly
    By Mack in forum Polaris PWC Performance
    Replies: 17
    Last Post: 06-21-2015, 01:28 PM
  2. '99 slth running hot - hellp needed.. =)
    By fr33man in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 06-16-2008, 11:51 AM
  3. STX DI Running Poorly When Hot... Ideas?? Help!?!?
    By Kawi_Mon69 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 09-23-2007, 09:44 PM
  4. 99 SLTH running lousy
    By Hammy129 in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 08-02-2007, 10:30 AM
  5. GTI running poorly, HELP
    By mtodd in forum 2-Stroke Performance
    Replies: 0
    Last Post: 06-12-2007, 12:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •