Results 1 to 4 of 4
  1. #1

    Problem with Block off's

    I have the riva pro block offs. When im driving the right side is totally dry as in no water sprays up from them but the left side it sprays water all over the back platform. I check both sided to see if the left side screws werent tight but they are identical, if i turn right the left one sprays if I turn left the left one sprays

  2. #2
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Wilmette, IL
    Did you silicone the gaps between the blockoffs and hull?

  3. #3
    ou812's Avatar
    Join Date
    Jun 2006
    Quote Originally Posted by RXP Steve View Post
    Did you silicone the gaps between the blockoffs and hull?
    Yeah that too!
    Is the block off flush with the hull on that side?

  4. #4
    yes the silicone is good and they are flush, weird cause they are identical

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RE Block off installed but.... (problem or ?
    By bruinsrme in forum 4-Tec Performance
    Replies: 17
    Last Post: 10-19-2007, 09:16 AM
  2. need help with oil injection block off 2006 gp1300rs
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-06-2007, 11:34 AM
  3. help with installing oil block off kit
    By joshxp in forum Polaris Open Discussion
    Replies: 4
    Last Post: 03-30-2007, 11:28 AM
  4. I wnet premix, with block off plate.
    By ccassone in forum 2-Stroke Performance
    Replies: 2
    Last Post: 04-20-2006, 06:02 AM
  5. HELP...I think I have a serious problem with the OPAS Blocks
    By Totallyblown in forum 4-Tec Performance
    Replies: 16
    Last Post: 01-01-2006, 09:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts