Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4

    Why is this GTX SC so slow?

    was slow from the get-go...

    Stock GTX SC with a pump wedge - 58's

    I added:

    RR High Boost SC Impeller w/ metal washers
    RXT Driveshaft, wear ring, and impeller
    3" Open air intake
    Free Flow Exhaust

    62.5 @ 7610 rpms ... so i gained 4+ mph... but it's still kinda way below what it SHOULD be doing

    definitely has much more noticeably improved acceleration, but this thing is finally just running stock speeds with these mods... everywhere i look so far everything looks ok


  2. #2
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    LOL....thats a funny post

    might need a different prop....i'm at 65-66 range with similiar mods..plus rr interecooler/thermo,riva filter and solas

  3. #3
    could be the hull Steve!...
    maybe not enough power to get full potential of RXT prop?
    maybe needs more fuel, 58psi reg?
    ...PR...

  4. #4
    Biotch better have my money rain or shine LiquidDI's Avatar
    Join Date
    Apr 2005
    Posts
    269
    seems good to me. My 03 does 60mph on a good day.

  5. #5
    my 03 did 62.5 stock

  6. #6
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    it's definitely far from good...

    i guess i could pop in a RXP fuel regulator for chits and giggles, but it's really not modded enough to need it at all, especially on a stock GTX ECU

    regardless... forget the mods and forget the fuel... wtf... why was it running 58 mph stock... i gained 4 mph... so if it did what it's SUPPOSED to stock, about 61, then i could be at 64-65 easily with the gains...

    the gains are there, but the speed isn't

  7. #7
    Biotch better have my money rain or shine LiquidDI's Avatar
    Join Date
    Apr 2005
    Posts
    269
    yeah I guess you are right. Most SC 4-Tec's do 60 stock. Sounds like you were 2mph off just from stock. Maybe you just agot a slow one from the factory????

  8. #8

    Join Date
    Jan 2007
    Location
    So. Calif
    Posts
    21
    My 04 is stock with metal washers new wear ring and an Impros bluprinted stock impeller, 93 hours turned 63.8 and 63.6 two day in a row against the wind. Air temp 103 at Needles Ca. Recorded with a 76Csx GPS 5/8 tank fuel and a cooler in the front. I must be lucky............

  9. #9

    Join Date
    Apr 2007
    Location
    The Bay
    Posts
    19
    My 04 GTX SC was doing 62-63 stock. I added a intercooler from a 06 RXP and a stg 2 kit from riva w/ out the riva cooler and it now GPS's 67-68.

  10. #10

    Join Date
    Jan 2007
    Location
    So. Calif
    Posts
    21
    I need some help here guys. With the stock SC boost levels being so low approx 5 lbs and the additional flow restrictionfrom an intercooler and a max rpm of 7650 how does the top speed increase? Are you changing the impeller? Where is the extra speed comming from?
    I would like to see some discussion on this for us lowly SC owners. Just what can be done without having to change out the ECU. Can you put in one of the available SC wheels for increased boost and change out injectors for increased fuel flow and still have the ECU within it's sensor ranges. Is there any way to push up the hp without pushing the RPM up to 8K+. With this, if possible, power increase would you be able to use a more agressive impeller to get more speed?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3rd aftermarket tach. Now why is this still happening?
    By ZeroClient in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 12-19-2013, 11:44 AM
  2. Why is this part so expensive
    By sea-one in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-06-2013, 05:50 AM
  3. Why is this driveshaft different like this????
    By blkturbo! in forum 4-Tec Performance
    Replies: 9
    Last Post: 04-22-2011, 11:59 PM
  4. Why is my SHO running so Rich when cruising?
    By BPnta in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-21-2010, 08:15 AM
  5. Why is this a news story?
    By IowanGPR in forum Open Discussion
    Replies: 0
    Last Post: 03-09-2008, 12:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •