Results 1 to 9 of 9
  1. #1

    Join Date
    May 2007
    Location
    Lexington, South Carolina
    Posts
    41

    '04 RXP Acting funny

    So I was out riding with some friends today and got some calm water conditions for once! As is was making some top end runs I noticed the ski seemed as if it was making more "blower whine" then normal. I removed to seat and the noise could be heard good! On the way back to the house I ran it to get an rpm number and its turning around 7850-7900! Im about to order my washers tomorrow so that when I get my trailer back Ill be able to replace those but can anyone give me some advice on what to check and such. I've built cars and such in the past but am new to the performance ski thing! Any advice or knowledge will be AWESOME! Sorry for the long post, just trying to learn fast. Forgot to mention that on the way back in when I let off to enter the cove I got a "!" beep as if it was low on fuel but I had half a tank and it didnt show a code!
    Last edited by scgolfer88; 05-21-2007 at 07:05 PM. Reason: forgot to add a detail


  2. #2

    hours

    how many hours on the ski?

    from what i have seen at the shop and heard on here you need to replace the bearings in the s/c at 100hrs

    definately get those washers in there before you ride again

  3. #3
    Tennessee's Avatar
    Join Date
    Dec 2005
    Location
    Mt. Juliet, Tn
    Posts
    502
    +1
    2
    I wouldn't ride it untill you get the washers and while the s/c is out you will be able to see if the wheel is rubbing the housing which might be the louder part. I dont know how many hours are on the ski but those new ceramic bearings might be in order with the new washers.

  4. #4

    Join Date
    May 2007
    Location
    Lexington, South Carolina
    Posts
    41
    Skis got 54 hours on it!

  5. #5
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    did you check to see if the intake tube came loose or off the Supercharger?

  6. #6

    Join Date
    May 2007
    Location
    Lexington, South Carolina
    Posts
    41
    No...The ski is still in the water because I wont get the trailer back till the end of this week cause my sisters gs is having some work done to it! I've gotta figure out the engine compartment so I can get aquainted! What does it take to remove the supercharger? Ive got a huge party coming up on the 1st and I need to get the washers in before then!

  7. #7
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Quote Originally Posted by scgolfer88 View Post
    No...The ski is still in the water because I wont get the trailer back till the end of this week cause my sisters gs is having some work done to it! I've gotta figure out the engine compartment so I can get aquainted! What does it take to remove the supercharger? Ive got a huge party coming up on the 1st and I need to get the washers in before then!
    Where to send it-http://www.greenhulk.net/forums/show...071#post243071

    How to remove- http://greenhulk.net/forums/showthread.php?t=13403

    I sure hope ure washers didnt go, cause then ure boat deff wont be ready for ure party.

  8. #8

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    DON'T RUN it till you check or replace bearings in the SC. I've had 2 SC's eat bearings under 20 hrs!

  9. #9
    Biotch better have my money rain or shine LiquidDI's Avatar
    Join Date
    Apr 2005
    Posts
    269
    I agree just put it up until you get those washers. Pull that SC'r as soon as you can and look at the washers.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 RXP will not start. Act like dead battery.
    By Five 0 in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-24-2011, 10:32 AM
  2. How To: Install RR ECU after the knock sensor update 04 RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 15
    Last Post: 06-14-2008, 12:13 PM
  3. 04 RXP - Leak into Hull thru VTS
    By joeg in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-01-2005, 02:21 AM
  4. Getting "Check Engine" message on 04 RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2005, 01:15 PM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •