Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8

    i'm stumped. need some outside help

    my 05 was really bogging down on me about a month ago. would barely get to 10 mph, seemed to be loading up on fuel, and had a really nasty smell to it. like unburned fuel. checked the plugs, they were fouled, changed them , seemed to run better, had a nasty bog up until 20 mph or so. then it would take off til around 40, then just felt really mushy. no power, kept trying to stall like it had a bad cat-con. sounded like something was rattling around inside the hull. like a piece broke off and was bouncing inside the waterbox. i was sure it was the cat-con. so i take it apart and it looks to be fine. i can see light thru it and is in one peice. maybe it is restricted? ski has about 40 hrs. the engine overheat warning lamp came on a few times and shut it off till it cooled. i have so much going on i cant think straight right now. any suggestions. i need this mofo ready for the mudbug


  2. #2
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    Have you checked your waterbox to see if there is a loose piece in there? Maybe ?

    Perhaps a baffle in the box itself has broken off and clogging things up?

  3. #3
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    no i havent. i felt like something was restricting the motor from breathing joe. has anyone ever seen a baffle break inside the waterbox?

  4. #4
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    check to see if the hose or clamp is loose on the exuast hose that exits the ski i've seen them come loose and the ski will fall flat on it's face.

  5. #5
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    You should slap a d plate in there Wake.Did the converter rattle at all?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Picture 294.jpg 
Views:	45 
Size:	147.9 KB 
ID:	25683  

  6. #6
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    because its choking on its own exhaust???

  7. #7
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by WATER WOODY View Post
    You should slap a d plate in there Wake.Did the converter rattle at all?
    Believe it or not with that water box like that the ski still ran good and i did not hear no rattle. I just noticed it when i was taking the exuast out to put a free flow.

  8. #8
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    bri, I can bring my polaris for ya to ride

  9. #9
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    Quote Originally Posted by SUCKMYWAKE View Post
    because its choking on its own exhaust???

    Yes, if you have a loose exhaust hose the ski will choke. However it shouldnt clear up at all. It should get worse at the higher rpms unless frsh air is blowing the exhaust fumes out?

  10. #10
    KamikazeGPR's Avatar
    Join Date
    Mar 2007
    Location
    Philadelphia
    Posts
    1,361
    +1
    99
    Did you take the cat out and hold it in your hands? When the cat in my 03 went at 75 hours the ski would run fine,then the buzzer would come on. When i took it out. The round part broke free from the outside part and would shift an inch from side to side but wouldnt fall out.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some Graphic Help!!!
    By ArmyRXP in forum Open Discussion
    Replies: 0
    Last Post: 02-13-2007, 05:42 AM
  2. Hey Guy's Need Some HP Help
    By somefun in forum 4-Tec Performance
    Replies: 3
    Last Post: 11-20-2006, 05:01 AM
  3. Need some more help i think
    By big83bronco in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 06-19-2006, 09:56 PM
  4. First test with 2 Intercoolers Need Some Impeller Help!
    By somefun in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-14-2006, 07:08 PM
  5. Need some quick help
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-04-2006, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •