Results 1 to 5 of 5
  1. #1

    MSX 110 Won't rev up fully

    2004 MSX 110 will only rev up to 6500, turbo guage 1 or 2 bars from top. Other than that it runs fine.

    I've found though, that if you hold it at 3300 for about 10 to 15 seconds, it will suddenly jump 200 to 300 rpm and if you punch it then, it will rev up to 7200, full on the turbo guage, and run great until you let right back off again.

    Any ideas what the problem may be?

    Thanks for any help.

  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    Hi Bill, WELCOME to the Green Hulk Forums!!!
    There are a few guys here that work with those Weber's and I'm sure they'll have some kind of answer for you.

  3. #3
    Could someone guide me to a better place to find a solution to this?
    None of the dealers near me seem to know anything about this model.

  4. #4
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    how new are those plugs? how old is that fuel? do you get a check engine light on? make sure that you hose from the turbo to intercooler is not leaking and is on all the way and the same with the hose from the intercooler to the throttle body as well. has this engine ever had any water in the intake tract? overfilled with oil? more information needed.


  5. #5
    Plugs have less than 10 hrs on them.

    No check engine light except at startup it blinks for ~10sec. Is that normal?

    Turbo hoses are in place and tight.

    2nd owner, but has never had water in intake or oil overfilled for the past 2yrs.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MSX 110 won't stop
    By greg123 in forum MSX/Matrix
    Replies: 6
    Last Post: 08-15-2009, 09:51 AM
  2. STX1100 won't rev out
    By wedoseadoo in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 05-09-2007, 09:36 PM
  3. MSX 150 won't start back up
    By Todd in forum Polaris Open Discussion
    Replies: 20
    Last Post: 04-28-2007, 07:26 PM
  4. MSX 110 low volt at batt
    By daddy in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 01-04-2007, 06:57 PM
  5. msx 110
    By posfit in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 10-02-2006, 05:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts