Results 1 to 4 of 4
  1. #1

    Smile ultra 150 question prop

    i put a solo prop in.. ive been reading and see that there is a close tolerance.. i put back the amount i took off.. i must say its sluggush out of the hole.. just wondering peoples thoughts.. also what about heads for performance next??

    Thanks guys


  2. #2

    new prop

    Did you check for clearance? It would be my bet your pump is too tight.

  3. #3
    way2fast's Avatar
    Join Date
    May 2005
    Melbourne Beach, FL
    I bet the clearance is too great. When I install Solas props in 150's, 9 out of 10 times one or two of the metal shims have to be removed to get the prop blades the correct distance from the pump wear ring.


  4. #4
    BrandonB's Avatar
    Join Date
    Jan 2007
    Benton, MS
    mine was shimmed too tight from the factory.. actually had a small rub..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 ultra 150 questions
    By 20rxp04 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 02-11-2009, 10:11 AM
  2. Ultra 150 questions
    By caliburst in forum Kawasaki PWC Performance (2-stroke)
    Replies: 17
    Last Post: 11-03-2008, 10:49 PM
  3. 2003 Ultra 150 Questions from a newbie
    By chinhminhdo in forum Kawasaki How To & FAQs
    Replies: 6
    Last Post: 09-26-2008, 08:35 AM
  4. '01 Ultra 150 Questions
    By ewilcox11 in forum Kawasaki Open Discussion
    Replies: 9
    Last Post: 03-17-2008, 09:55 PM
  5. Ultra 150 question
    By watermedic in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 06-01-2007, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts