Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    msx110 motor trouble

    Hello! I am new to the board. I just aquired a 2004 msx110. I am a first time owner of a ski. I"m pretty mechanically inclined. I bought the ski and the owner told me it has a low cylinder. I took it home and did a compression check, got 140 for the front and 20psi on the rear cylinder. I tried to take the head off but everything is so tight on these, its like putting socks on a rooster. So i just took the whole motor out and wanted to check everything out. Anyways got the head off and found a copper peice stuck on one of the intake valves. Now i suspect that was the culprit. I looked over the pistons and cylinder walls and they looked good. When i was taking the intake stuff off there is that roundish looking barrel that the throttle body bolts to, well i saw some copper peices laying on the bottom, the same material that was stuck in my intake valve. Question: where would this peice have introduced from? I am new to this 4 stroke jetski efi"s. Anyone with suggestions or comments about this and what i should do or check please chime in. Much appreciated! Thanks!


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    WELCOME to the Green Hulk Forums!!!!

    There are a couple of members with the Weber engines that can probably point you in the right direction.
    I'm also sure Jay or Chip can help you out, they should be around sometime tomorrow, hang loose.

  3. #3
    twinstack1 twinstack1's Avatar
    Join Date
    Mar 2007
    Location
    Dalzell, SC
    Posts
    141
    In the mean time, you may wanta ask the former owner if he's ever counted his pocket change over the air box!

  4. #4
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu. Live In Los Angeles.
    Posts
    841
    How about some pics too?

  5. #5

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9

    Cool

    only thing I can thing of is intercooler falling apart

    later cd

  6. #6

    Join Date
    May 2007
    Location
    Middleburg,FL
    Posts
    359
    +1
    1
    What do the valves look like. This is an overhead valve machine. I doubt it would be pieces from the intercooler. It could be the turbo vanes. Where was the ski ran, fresh or salt water. Maybe intercooler, but doubt it. Still your bigs problem is compression. Fellow 110 owner. Post pictures.
    Last edited by f150vtx; 05-24-2007 at 03:35 PM.

  7. #7

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9

    Cool

    there ya go,what the heck do I know!
    only thing between turbo and intake is intercooler,made out out brass tubes(at least 150 use tubes)

    later cd

  8. #8
    sorry i cant post any pics i dont have the right camera. I was thinking the intercooler myself i guess its the only logical explanation where this material would be introduced from. The valve itself looks ok but i"m gonna replace it anyways with a new valve seal. When i took the head off i had to brake a link in the camchain then the chain fell to the bottom of the crankcase. Can you get a new link for the camchain? Thanks for your help guys!

  9. #9

    Join Date
    May 2007
    Location
    Middleburg,FL
    Posts
    359
    +1
    1
    Your right, my bad. That is the only place you would get copper pieces. Have you ran any water in the cooling loop. If the intercooler is where the pieces came from then you probably have a bad intercooler. If it is leaking you my have just bent the valves, but check the seating of the new ones. After posting I checked my ski to find that the intercooler was loose and moving around. Front two intercooler holder bolts seperated from the rubber. Gorrila glue it. Sorry about the bad info earlier. Make sure the intercooler holds water and doesn't leak.

  10. #10

    Join Date
    Oct 2006
    Location
    Beaver Falls, PA
    Posts
    281
    I thought I heard jay say he had one like this, and stated it was some flashing that was from in the intercooler that had shook loose finally. Reason being not the intercooler coming apart was that if it was that baby would be spewing lake water down into the motor being those were water cooling rods inside the intercooler with lake water. I recall that all he had to do was lap the valve seats and it was fine. Gaskets and time pretty cheap repair.

    Sweet buy if that was all that was wrong with the unit.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 2004 Polaris MSX110 Motor Brackets / Hardware
    By grumpy_steven in forum Polaris Classifieds
    Replies: 2
    Last Post: 08-23-2016, 07:36 AM
  2. Trouble Seating Flywheel on Kawasaki Ultra 250 motor(STX-15F)
    By 11FALLINE in forum Kawasaki Projects
    Replies: 1
    Last Post: 08-27-2015, 02:24 AM
  3. Trouble with 150 weber motor in a hydrospace
    By terkkata in forum MSX/Matrix
    Replies: 1
    Last Post: 07-23-2013, 10:11 AM
  4. Need complete motor turbo for a MSX110
    By RACINGHART03 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 04-10-2010, 08:10 PM
  5. motor trouble
    By heinalanka in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-28-2007, 09:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •