Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 26
  1. #11

    Join Date
    Aug 2017
    Location
    Colleyville, Texas
    Posts
    15
    Well it looks like you are correct sir...reed valve is broken...so the question is do i replace all of them or just that set? Anyone have any recommendations?


    Click image for larger version. 

Name:	20170812_103043.jpg 
Views:	26 
Size:	51.9 KB 
ID:	418889Click image for larger version. 

Name:	20170812_103047.jpg 
Views:	23 
Size:	51.8 KB 
ID:	418890Click image for larger version. 

Name:	20170812_103233.jpg 
Views:	23 
Size:	71.7 KB 
ID:	418891Click image for larger version. 

Name:	20170812_103231.jpg 
Views:	22 
Size:	42.8 KB 
ID:	418892

    Sent from my SM-G955U using GreenHulk PWC Performance mobile app powered by Tapatalk

  2. #12
    Bdesim's Avatar
    Join Date
    Aug 2012
    Location
    Chicago
    Posts
    221
    +1
    4
    They are 20 years old. I would buy a set and call it a day. Hopefully that fixes your issues.

    Did you go through the carbs yet?

  3. #13

    Join Date
    Aug 2017
    Location
    Colleyville, Texas
    Posts
    15
    Quote Originally Posted by Bdesim View Post
    They are 20 years old. I would buy a set and call it a day. Hopefully that fixes your issues.

    Did you go through the carbs yet?
    I know I should but I dont want to rebuild them and have to adjust them at the end of the season. I know they were rebuilt last year according to the lady she sent me all the reciepts with it. All 3 inlets are spraying fuel. I was going to replace the fuel lines and change out the reeds and see what happens.

    Will these be alright for a stock engine?

    http://www.watercraftsuperstore.net/...1996-2005.html

    Sent from my SM-G955U using GreenHulk PWC Performance mobile app powered by Tapatalk

  4. #14
    Bdesim's Avatar
    Join Date
    Aug 2012
    Location
    Chicago
    Posts
    221
    +1
    4
    Those should be fine. I've never used sbt's reeds before. I don't see why they wouldn't be fine for a stock ski unless someone else here has some other experience with them.


  5. #15
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    850
    +1
    19
    The hull damage is a nothing-burger...epoxy and move on.

    But something got loose and had a party in the PTO cylinder. My experience is that engine needs to come apart to check for metal bits in the crank.

  6. #16

    Join Date
    Aug 2017
    Location
    Colleyville, Texas
    Posts
    15
    Quote Originally Posted by Bdesim View Post
    Those should be fine. I've never used sbt's reeds before. I don't see why they wouldn't be fine for a stock ski unless someone else here has some other experience with them.
    Well I ordered some new ones so we will see what happens when they get in. I also noticed that someone jacked the flame arrestor air filter, It didnt have one with it they were like $80 new everywhere. I found a used one on ebay for $25. My budget for each ski is $500 total. I think Im at $430 on this one so far on this one, Im hoping thats all it is, because I still need to get some new hydroturf on it.

    Sent from my SM-G955U using GreenHulk PWC Performance mobile app powered by Tapatalk

  7. #17

    Join Date
    Aug 2017
    Location
    Colleyville, Texas
    Posts
    15
    Quote Originally Posted by stimpsonjcat View Post
    The hull damage is a nothing-burger...epoxy and move on.

    But something got loose and had a party in the PTO cylinder. My experience is that engine needs to come apart to check for metal bits in the crank.
    This one is next after I get the other one running. I have some epoxy from another boat project I was doing so I will probably start on that this weekend. I have an auto lift in the garage I was thinking about using to get it up in the air instead of flipping it over but we will see.

    Unfortunately this one did not come with a title, like I said I mainly bought it for the trailer but luckily in Texas we have a hull number search to find the owner. Here's the link for anyone buying a questionable ski in Texas.

    https://apps.tpwd.state.tx.us/tora/jump.jsf

    I found the lady on facebook and I was going to message her today to see if I can throw her $20 or something to file a lost title. She lives in the next town over, but im going to wait to put money in it until I get a title otherwise il part it out or get another hull.


    Sent from my SM-G955U using GreenHulk PWC Performance mobile app powered by Tapatalk

  8. #18

    Join Date
    Aug 2017
    Location
    Colleyville, Texas
    Posts
    15
    Got the new reed pedals in and installed them on the cages about to install them but which direction does the rubber flap go? is it on top or bottom?

    Sent from my SM-G955U using GreenHulk PWC Performance mobile app powered by Tapatalk

  9. #19

    Join Date
    Aug 2017
    Location
    Colleyville, Texas
    Posts
    15
    Well put new reed pedals on, new gaskets got it started and tbis is what its doing...having a little backfire in the exhaust now. Still bogging it will start and idle though. All 3 cylinders were hot to touch. Where should i check next?



    Sent from my SM-G955U using GreenHulk PWC Performance mobile app powered by Tapatalk

  10. #20
    Bdesim's Avatar
    Join Date
    Aug 2012
    Location
    Chicago
    Posts
    221
    +1
    4
    Still sounds like a fuel delivery problem to me. I still think you should go through those carbs.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 04-15-2017, 04:37 PM
  2. Ski Ready and got the new upgraded Intercooler!!
    By Yanksfan in forum 4-Tec Performance
    Replies: 27
    Last Post: 12-23-2015, 09:48 AM
  3. New Member saying hi and a couple questions.
    By Mikenj in forum PWC Fishing
    Replies: 7
    Last Post: 06-13-2015, 01:02 AM
  4. Replies: 4
    Last Post: 01-23-2013, 07:29 PM
  5. I Think I Got The Bug Contageous Isn't It?
    By rmk82nd in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 05-21-2011, 05:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •