Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 42
  1. #1
    Biotch better have my money rain or shine LiquidDI's Avatar
    Join Date
    Apr 2005
    Posts
    269

    Got a problem guys need some help..

    I'm down at the lake of the ozarks working on my 03 SC 4-Tec. I changed the oil and the filter but I noticed one of those cheap plastic pieces on the oil filter cap had broken off and was sitting in the bottom of the canister. When I tried to get it out it slid under in the canister where I can't get to it. Question, can I run the ski like this? If not how hard is it to get the canister off to clean it out? I believe the ski ran all summer like this last year. Any help would be great. I left my RXP at home so if I can't ride this thing I'm skiless the whole weekend


  2. #2
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    I know if you buy a new oil filter cap they dont come with the plastic inside anymore. Try taking a shop vac and sucking the plastic piece out...mebbe it will come out..

  3. #3

    Join Date
    Nov 2005
    Location
    Minnesota
    Posts
    100
    Call Dan( JD1) at Jetdraft right there in Lake of the Ozarks. He might be able to help you out. 1-573-216-0690.

  4. #4
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Yea, call JD...

    and check your email FOOL, i sent you chit!

  5. #5
    Biotch better have my money rain or shine LiquidDI's Avatar
    Join Date
    Apr 2005
    Posts
    269
    I will have to call JD1 and see. Thanks for the heads up. How much pressure goes through that filter? I'm guessing it's not as important as the oil pumps. If the ski went all summer last year like this then I hope it will be ok. I don't have a trailer here to take it out. I will give JD1 a call.

  6. #6
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    pinch an o-ring on the oil filter cap and watch the oil squirt out... there's pressure there..

    it's not like oil is just injected in there and trickles thru the oil filter canister... it's PUSHED thru there by the oil pumps

  7. #7
    Biotch better have my money rain or shine LiquidDI's Avatar
    Join Date
    Apr 2005
    Posts
    269
    well, I have tried everything possible to get it out with no success. So basically either the engine will chew it up or I will be rebuilding it. I'm going to run it. No way I'm paying $1500 to have the engine pulled. I would rather take a chance of blowing her up and having to fix the engine.

  8. #8

    Join Date
    Jul 2005
    Location
    Southampton, UK
    Posts
    190

    Don't run it!!! - Oilway can get blocked!!!

    We had an N/A 4 Tec and had the same problem. I paid for a new metal cap but when I researched the problem I found out this was quite a common problem.

    IF you're unlucky, the plastic piece can block an oilway - causing the motor to blow up!! i.e. The problem is not so much the oil pumps, more oil starvation when the oilway gets blocked. I understand this is why the design was changed. Sorry to be alarmist, but I really would try to get the piece out.

  9. #9
    Biotch better have my money rain or shine LiquidDI's Avatar
    Join Date
    Apr 2005
    Posts
    269
    What would you guys do? Would you pay the $1000-$1200 to have the engine pulled?

  10. #10
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    i'd sure as heck wrestle with it for more than a couple hours...then some more....then, I'd pull it myself. save big $......even if you have to buy the tools you need.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2 Problems here.. need some help please - 98 GP1200
    By NCMTS in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 08-27-2012, 04:46 PM
  2. Hi guys need some HELP
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 10-25-2007, 10:36 PM
  3. need some help from the US guys
    By winterstick in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-28-2007, 09:47 PM
  4. need some help guys...
    By minersny in forum Polaris Open Discussion
    Replies: 6
    Last Post: 03-24-2007, 01:00 PM
  5. Need some help guys, Lost 500rpm
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2006, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •