Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1

    I knew there was no way I would finish flawless!

    After all that happened and all I got through....this happens....Seems like my POS torque wrench dedided not to work! I was putting the valve cover and look what happened.....And it worked perfect while torquing down the rocker arm assembly...

    Driving to PPG tomorrow to drop it off....
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00646.JPG 
Views:	77 
Size:	877.2 KB 
ID:	25885   Click image for larger version. 

Name:	DSC00647.JPG 
Views:	80 
Size:	905.5 KB 
ID:	25886   Click image for larger version. 

Name:	DSC00648.JPG 
Views:	50 
Size:	796.9 KB 
ID:	25887   Click image for larger version. 

Name:	DSC00649.JPG 
Views:	56 
Size:	855.4 KB 
ID:	25888   Click image for larger version. 

Name:	DSC00650.JPG 
Views:	61 
Size:	836.1 KB 
ID:	25889  


  2. #2

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281
    Did you wrench it off?

  3. #3

    ppg

    dang geo sorry about all the rotten luck

    sounds like you should just drop it off in the future and pay the man instead of all the grief you are having to endure over breaking stuff


    what size torque wrench are you using


    an inch pound wrench might be in order for valve covers next time

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Man, that sux. All you really have to do is barely snug them up with a ratchet.

    Did you strip one of them or all of them?

    You can fix that with a helicoil kit (bring to someone experienced )

  5. #5
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    Quote Originally Posted by Green Hulk View Post
    Man, that sux. All you really have to do is barely snug them up with a ratchet.

    Did you strip one of them or all of them?

    You can fix that with a helicoil kit (bring to someone experienced )
    Only two are that bad since I only tried it on three and then took the out again to see and found this....

    I have helicoil....you know what size I need?

    Im still gonna drop it off though....Im done with this shit.

  6. #6

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281
    Quote Originally Posted by GeoRXT View Post
    Only two are that bad since I only tried it on three and then took the out again to see and found this....

    I have helicoil....you know what size I need?

    Im still gonna drop it off though....Im done with this shit.
    Like a smart philosopher once wrote:

    Get a stock ski, keep it stock, ride it, and call it a day!

  7. #7
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    for future reference valve covers just need to be snugged down, no need to use a torque wrench.

  8. #8
    xenonx's Avatar
    Join Date
    Feb 2006
    Location
    Woodland Hills, CA
    Posts
    237
    OUCH!

  9. #9
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    Quote Originally Posted by _Lurker_ View Post
    for future reference valve covers just need to be snugged down, no need to use a torque wrench.
    I was following rivas instructions...

  10. #10
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    you went 7 foot pounds and it stripped?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. There is no way I could ever do this
    By Rampage in forum Open Discussion
    Replies: 20
    Last Post: 09-16-2010, 10:17 PM
  2. Then there was no POWER.........
    By RichieFZR in forum Yamaha PWC Performance (4-stroke)
    Replies: 29
    Last Post: 02-26-2010, 01:20 AM
  3. Replies: 9
    Last Post: 07-25-2008, 07:39 PM
  4. Replies: 8
    Last Post: 07-25-2008, 07:35 PM
  5. Once upon a time there was an old ski....know as the blaster
    By Mpeavler in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 01-15-2006, 10:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •