Results 1 to 7 of 7

Thread: pump question

  1. #1
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113

    pump question

    after re-installing the pump should i put silicon sealant around the pump housing?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    NOOOOOOOOO!

    The rubber seal does the job.

  3. #3
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    ok good, haha, i installed it already without silicon but i have my dad addicted to this site now and he has been reading a lot latley, and he read somehting about that on a post waaaaaayyyyy back (hes very intersted in this now and is learning and catching up). thanks jerry

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    Tell your dad welcome to the site and tell him to sign up with his own name

  5. #5
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    yea, i got him to sign up the other day, he hasn't posted anything yet, hes still catching up and reading. hes amazed about this site and how much great info it has and amazed at what u guys are doing to these skis. im excited to mod his ski whenever he gets a new one! im sure he wil lbe posting questions someitme soon!

  6. #6
    way2fast's Avatar
    Join Date
    May 2005
    Location
    Melbourne Beach, FL
    Posts
    4,013
    +1
    3
    If you use silicone you would have one bitch of a job if you wanted to remove the pump again !!!!

  7. #7
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    haha yea i was just thinking about what i asked actually, not the smartest, haha o well!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. impeller and pump question??????????????????
    By JOSE13RT in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-07-2006, 11:28 PM
  2. Bilge Pump Questions
    By Piney in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 03-18-2006, 09:33 AM
  3. more pump questions
    By chip in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 02-25-2006, 08:00 PM
  4. Island racing and 05 pump question ??
    By slow1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 02-17-2006, 12:27 AM
  5. pump question
    By skillet in forum 4-Tec Performance
    Replies: 16
    Last Post: 01-06-2006, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •