Results 1 to 7 of 7
  1. #1

    Survey: Anyone with a Supercharged Speedster that didn't have the washer fail?

    Please post how many hours you have on it.

    It's hard to tell exactly how common the failure is if only those who have experienced the failure post, so maybe this will give us an idea of the frequency.

    I plan on replacing the washer ASAP, but still want to guage my chances of a failure this weekend....


  2. #2
    cyoungesq's Avatar
    Join Date
    Apr 2006
    Location
    Bridgeport, CT
    Posts
    217

    original s/c clutch washers

    50 hrs of thrashing, pounding and occasional launching/jumping on OEM washers w/o probs. When swapped for steel, the ceramic washers looked fine...no chips, cracks, or other indications of stress/fracture. Buddy with similar hours on a similar boat found fractures in his washers when he swapped ceramic for steel...couldn't have been closer to disaster. There appears to be no rhyme or reason or predictability as to the time of their failure.

  3. #3
    Speed200's Avatar
    Join Date
    Apr 2007
    Location
    Prairieville, LA
    Posts
    112
    No problems so far with about 18-20 hours. I'm at double the normal risk too!!I Will be pulling the chargers off after this season and sending them to Jerry.

  4. #4
    Right around 15hrs here with no problems.. but if they are ceramic they could go at any time.. its basically like glass..

  5. #5
    sarasotabrit's Avatar
    Join Date
    Apr 2007
    Location
    Sarasota Florida
    Posts
    40
    13 Hours here and no SC problems yet ( cross fingers ).

  6. #6
    Speed200's Avatar
    Join Date
    Apr 2007
    Location
    Prairieville, LA
    Posts
    112
    Change of plans. As long as Jerry can swap out my washers next week I will be pulling the chargers off this weekend and putting in the metal washers. I just getting a little nervous and since the intakes are off now it's a good time.

  7. #7

    Join Date
    Dec 2005
    Location
    Austin, TX
    Posts
    33
    50-55 hrs?? (around there) No issues

    Upgraded to RR H/D kit, and swapped out the ceramics for metal ones along with replacing the SS bearings with ceramic bearings. The ceramic washers looked fine just as cyoungesq mentioned.

    I also believe incorrect assembling from the manufacturer is also adding to the problem. This is probably why some experience failure sooner than others under calmer riding conditions. IMO.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. can anyone help with two jet skis that don't start
    By DANES in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 06-04-2013, 03:22 PM
  2. Anyone have the sheet that comes with the Lc-1
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-21-2011, 01:03 AM
  3. Hey anyone with dual carbs that has had them apart!!!
    By chritopherlloyd in forum Yamaha Old School Skis
    Replies: 11
    Last Post: 06-11-2008, 12:10 PM
  4. models that i think have the same lines in design
    By sleblanc in forum Polaris Open Discussion
    Replies: 2
    Last Post: 03-22-2007, 10:16 AM
  5. ? for anyone with a modded rxp
    By seadoo02xp in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-27-2005, 05:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •