Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33
  1. #1
    1FASTXC's Avatar
    Join Date
    Mar 2007
    Location
    Wisconsin
    Posts
    412
    +1
    2

    Need help with my 1050 mph

    I posted last year over on the other site and got a little help, but i'm back at it and need help here. My ski is a 97 1050 with stock motor just boyesen reeds. I have an O.P. ride plate and an R&D shortwing intake grate. I've been trying to get mph out of this thing now but it just won't budge. At the end of last season i was running about 57-58 mph consistantly with a solas XII prop at about 6480 rpm. I took it out today to set a baseline and hit 58 mph with it again. I just picked up a 13/24 ssl skat impeller from polaris nut and a brand new 6 vein s.s. stator and wanted to stage tune with new impeller on old pump, then old impeller on new pump, then new impeller new pump. Not possible because my solas impeller wouldn't fit over the boss on the stator. No big deal, i'll turn down the o.d. next week, but anyway, so i put the 13/24ssl on the new 6 vein pump and bolted it up hoping for more mph. I hit 59 mph at 6510 rpm. If i remember right, absentx and wetherby are running in the 60+mph range with their 1050's so i'm a little frustrated why mine won't. Any help is appreciated. I do have ported cylinders and 92 oct. hot seat heads to try too, but i think it should run better stock than it does now. HELP!!!


  2. #2
    Banned User
    Join Date
    Aug 2006
    Posts
    1,236
    I remember the 97 Sl was using a nujet 6.5 as stock. Never used the solas, so I can't comment there.
    The stock 99 uses a nujet 7.0, so that'll naturally help there.

    If you're using the OP long plate, it'll drive the nose in the water. Just ask Joe96xp.

    And yes, the 99 SLX was running ~62-63 using the 009 cylinders with stock porting, bored 1mm over, with 92 octane domes. And under Ideal conditions. And RPM, if I remember correctly was around 6700-6850.

  3. #3
    1FASTXC's Avatar
    Join Date
    Mar 2007
    Location
    Wisconsin
    Posts
    412
    +1
    2
    Wetherby, what were you running for intake grate and rideplate? My rideplate isn't the real long one, just the same length as stock. Also what impeller? I thought you had a 13/24 ssl too. I'm going to check my wash, but i think my stock jetting is quite fat. Could explain the lower rpm. I believe my stock impeller was a skat swirl, like 17/24. It's worn pretty bad otherwise i'd try it again.

  4. #4
    Banned User
    Join Date
    Aug 2006
    Posts
    1,236
    Stock grate and plate.

    The OP plate comes in two lengths, long like stock long, and short like the older short pumps.
    The short is good for tight corners, but I haven't had the chance to use mine.
    And the long is supposed to improve rough water handling. Ken made no claims to increased speed.

  5. #5
    Banned User
    Join Date
    Aug 2006
    Posts
    1,236
    Running stock Polaris/nujet 7.0, 6-vane, 4* wedge.
    Trim (slow trim) at 2 bars above nuetral. Standing on the rear step, down stream, on perfect glass at 7am.
    Temp was 65*, and humidity was 70%
    Stator and impeller are in like new condition.

  6. #6
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    Location
    Oswego,NY
    Posts
    919
    +1
    6
    rpm's sound like you need to take some prop out of that boat. like weatherby stated try the 7.0 nujet. would like to see 6700-68ish for rpm. don't swith too many things at once when change combo when looking for speed.

    JAY

  7. #7
    1FASTXC's Avatar
    Join Date
    Mar 2007
    Location
    Wisconsin
    Posts
    412
    +1
    2
    Is that where these 1050's make power at 6700-6800? In my factory polaris manual it claims 120hp at 6500 for a 97 1050. That's why i was running it there. I didn't want to change alot all at once, i wanted to stage tune it so i could see what each individual part did, but the damn "asia trend" s.s. stator wasn't machined to fit my solas impeller. I gotta fix that next week.

  8. #8
    Banned User
    Join Date
    Aug 2006
    Posts
    1,236
    While I don't have a dyno chart in front of me, I'm assuming peak HP would be in that neighborhood. The doesn't necasarily limit the peak rpm though.
    Last time out, before I pulled the 1050 for the 1200 swap, I was getting consistant rpm's around 6800rpm.

    Also, doesn't it take some extra torque to run a set-back impeller??

  9. #9
    PolarisNut's Avatar
    Join Date
    Dec 2006
    Location
    Lower Michigan
    Posts
    1,809
    Quote Originally Posted by 1FASTXC View Post
    Is that where these 1050's make power at 6700-6800? In my factory polaris manual it claims 120hp at 6500 for a 97 1050. That's why i was running it there. I didn't want to change alot all at once, i wanted to stage tune it so i could see what each individual part did, but the damn "asia trend" s.s. stator wasn't machined to fit my solas impeller. I gotta fix that next week.
    That is the Solas impeller that is at fault...some of their hubs aren't big enough...not sure why. IMO that Solas XII is too steep for that motor. I bet you'll see the rpm come up with that Skat 13/24SSL. My 1050 w/ those cylinders and heads would run 6700 rpm with a 7.0 nujet and a bit higher with that SSL prop. I know when mine was down on timing, it wouldnt pull the rpm. Have you verified that? I'm sure your lack of mph is rpm related. Also, I've found once you bump the compression up with those heads, the motor doesn't want to rpm quite as much. Some of you guys are running a nujet 7.0 at 6800 on a stock 1050? FWIW, I've run two different MFDs in my ski, and found the rpm was different by over 100, so I've got to question the accuracy of some of those things?
    Last edited by PolarisNut; 05-26-2007 at 05:54 PM.

  10. #10
    1FASTXC's Avatar
    Join Date
    Mar 2007
    Location
    Wisconsin
    Posts
    412
    +1
    2
    Actually Nut the rpm is almost identical between the impeller i got from you and the XII i had on there. I only bought the XII because i got it cheap off ebay and figured i'd try it for the hell of it. I never thought my ski would even pull it. It must be off a little from the factory or something, cause my ski runs 6570 rpm or so with it. Same as the 13/24 ssl i got from you. Maybe i'll try a little smaller prop to see if i gain more mph with more rpm. Part of it may be jetting too. The pistons i put in there are wiseco pistons, but they're the new style not like the ones i got from you, and there is no hole in them to "blow" back on the boost port like the stock ones. That could possibly be making it run richer.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Parts needed. Help with my RXP build
    By caliburst in forum Sea Doo Classifieds
    Replies: 30
    Last Post: 11-03-2008, 06:19 PM
  2. need help with my gprxp
    By cliff0413 in forum Conversion PWC Performance Skis
    Replies: 28
    Last Post: 08-18-2008, 05:04 PM
  3. Need help with my GP1200!
    By MTAINFLA in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-28-2008, 02:13 PM
  4. Need help with my C180
    By Atlantis in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 09-12-2007, 08:46 PM
  5. Need Help with my STLX 1050
    By Johnquest in forum Polaris Open Discussion
    Replies: 18
    Last Post: 03-15-2007, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •