Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1

    04 rxp shy with the performance

    i just put metals in an 04 rxp, and all its got is 64mph.at 8000rpm it has a riva grate, and a shorty airfilter, thats all, weres its speed gone ?
    Last edited by jetskibill9999; 05-25-2007 at 08:41 PM.


  2. #2
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    I would be looking at the pump (prop/wear ring).

  3. #3
    Banned User
    Join Date
    Jul 2006
    Location
    upstate NY
    Posts
    289
    Did you set you clutch slippage?

  4. #4
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    I don't think he would be getting 8000 if it were slipping .

  5. #5
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Its the propodopolis. its a greek prop, hence the problem..

  6. #6

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by Vman View Post
    I don't think he would be getting 8000 if it were slipping .
    the slippage is none, the wear ring is the best and the prop is the dogs, (even if its standard) i think i might look at the opas, incase its not lifting?

  7. #7
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    the RXP opas does not move up and down.....only 3 seaters...

  8. #8

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by meeper View Post
    the RXP opas does not move up and down.....only 3 seaters...
    in that case i was riding a very slow rxp? i can't see the probs, can you ?

  9. #9

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by RXP Steve View Post
    Its the propodopolis. its a greek prop, hence the problem..
    rxp steve are you goosed?

  10. #10
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    i bet if you went back to stock grate RPMs would pick up and so would speed.....the riva grate should be used with an aftermarket prop and intake...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. stock 04 rxp what should the sc slip be?
    By b_dolla44 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-07-2011, 10:25 AM
  2. 04 RXP Problems with codes and ecu follow up to previous post
    By davidrxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-26-2010, 08:42 PM
  3. 04 RXP bogging with Les ECU
    By Water4fire in forum 4-Tec Performance
    Replies: 21
    Last Post: 05-12-2010, 09:17 AM
  4. WANTED: 04 RXP ECU WITH 65 or less hours
    By wisconsin_quat in forum Sea Doo 4Tec Skis
    Replies: 3
    Last Post: 08-10-2009, 02:02 PM
  5. What is an 04 RXP worth on the open market?
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-08-2006, 08:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •