Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Unhappy Sucked up rock - wrecked the prop!

    Just been out on the Brisbane river and being a total moron, put it in reverse near the muddy bank. Terrible grinding and banging noises made it clear I'd screwed up. Rock is still stuck in there, but the prop looks stuffed.

    Any idea want sort of $$ I'm looking at for a replacement? Is aftermarket the way to go?


  2. #2
    BERMY_BOY's Avatar
    Join Date
    Jan 2007
    Location
    bermuda
    Posts
    120
    Quote Originally Posted by bulletboy View Post
    Just been out on the Brisbane river and being a total moron, put it in reverse near the muddy bank. Terrible grinding and banging noises made it clear I'd screwed up. Rock is still stuck in there, but the prop looks stuffed.

    Any idea want sort of $$ I'm looking at for a replacement? Is aftermarket the way to go?

    aftermarket $244.00 I think, not too sure if they are out yet good searching for the aftermarket 1

  3. #3
    Pull your pump and send the prop to IMPROS. He should have you back and running for under $100. Call and ask Dave if you can send him the whole pump so he can check the housing for you too.

  4. #4
    thanks Skip, problem is I'm in Australia. I wouldn't trust the dealer I bought the ski from to inflate my tyres.

    I'll pull it apart tomorrow and will see what the actual damage is. Maybe if I post some pictures I can get some advice.

  5. #5
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Stock props are @ 365.00 us.

  6. #6
    Impros's Avatar
    Join Date
    Apr 2006
    Location
    So Cal
    Posts
    205
    +1
    2
    Hey there guys.
    We can sure fix the damage to the impeller/pump. Bullet, if sending it in is not economically desireable, we can ship you a new aftermarket impeller. I have prototype impellers that I used for testing on the Ultra that are equivalent to the stock impeller on rpm, bottom end and speed. We're still testing the ski, but can send you one for substantially less money than the OE replacement price.
    Thanks
    David

  7. #7
    David, attached are some pictures which show the damage. The pump housing has some minor damage, but the impellor is pretty bad. Can you fix both?

    I can fedex the whole lot to you tomorrow. Any estimate on cost would be great.

    BTW, the last picture shows the rock that did the damage. - Also, silicone must be cheap in the US, because Kawasaki seem to slap the stuff all over the place, crazy.

  8. #8
    having trouble with attaching pics

  9. #9
    tomgtv's Avatar
    Join Date
    May 2006
    Location
    Weston Florida (Ft. Lauderdale)
    Posts
    1,744
    +1
    1

    pix

    to attache pictures you go to "Additional Options" just below where
    you type in the text block.

    Click on "Manage Attachements" and a box pops up for you to
    "Browse" and find the pix on your computer. Then upload them
    in this window. Close that window and "Submit" and you're done.

  10. #10
    Another try.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Picture 001.jpg 
Views:	109 
Size:	2.94 MB 
ID:	26051  

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sucked up rocks, vane, prop and housing damage
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 09-08-2008, 12:11 PM
  2. 2008 rxpx sucked up rocks
    By stevierxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-02-2008, 01:47 PM
  3. Sucked up rocks :( Pump support teeth question?
    By cfnnslsq in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 09-02-2007, 05:54 PM
  4. friend sucked up rocks on my 06-1300r, impeller bad, jet pump doesnt look good
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 23
    Last Post: 08-03-2007, 07:30 PM
  5. Sucked up rocks!!!!! Help me with the damage!
    By TorquePhoto in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-01-2006, 03:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •