Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: My New Numbers

  1. #1
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608

    My New Numbers

    Hey guys,

    Last year I was running bone stock 03 gpr at 63.9 on GPS.

    Over the winter season I put on the following mods:

    Jim's FF plate (no holes filled yet)
    head milled 150 psi
    Solas 13/19 concorde
    800 grate
    protec reed stuffers
    R&D Plenum F/A
    D-plate/resistor
    EFI controller
    waveeaters clips and couplers
    bucket mods

    2 weeks ago I ran 71.8 and 71.4 consistantly. I haven't been able to tune much but I did take the pump back off today to remove the small cone in front of the impeller and re-yamabond the pump. I then changed the plate's shims b/c I suspected drag. I had J-gapped plugs that installed and also indexed them with my kit I got last week. Today I was in a crunch for time as it has been raining on and off for the whole day. I decided to try and make it out for a couple runs. at 897ft 75* 87% humidity I ran at 74.8 mph GPS then 74.5 on my second run. didn't have time for any more. I haven't tweaked my EFI much more than 20 minutes worth. haven't found the sweetspot there yet.

    First off I'd like to thank SpeedJunky(kevin) for helping recommend mods that would help me... He's answered so many questions (newbie/annoying ones) and helped a lot. Also thanks to Carl at IR and Jim for helping me as well, both have answered multiple phone calls from me. Thanks to everyone for your help.

    I'm not content yet. How much more speed is expected from tweaking the EFI? I guess its hard to tell I could have it dead on but that is unlikely. I feel like I'm running rich but don't want to lean her out too much. Is there a kit for removing trim tabs? I suppose you'd want to fill the holes up with a bolt or something yet I want to be able to install them if my results aren't good.

    Is there a hidden post on tweaking the EFI? search shows nothing.

    Thanks EVERYONE and thanks to greenhulk.net for existing.


    Ben


  2. #2
    Chrisrokc's Avatar
    Join Date
    Apr 2006
    Location
    Oklahoma City, OK
    Posts
    3,667
    Now that is moving! Good job

  3. #3
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Those are great #s Ben! Especially with the old style pump.

    Give WFO a ring, he seems to have the EFI thing figured out.

  4. #4
    My son (mohawk man) jeffsntx's Avatar
    Join Date
    Sep 2006
    Location
    Belton TX
    Posts
    2,598
    +1
    1
    Quote Originally Posted by IowanGPR View Post
    Hey guys,

    Last year I was running bone stock 03 gpr at 63.9 on GPS.

    Over the winter season I put on the following mods:

    Jim's FF plate (no holes filled yet)
    head milled 150 psi
    Solas 13/19 concorde
    800 grate
    protec reed stuffers
    R&D Plenum F/A
    D-plate/resistor
    EFI controller
    waveeaters clips and couplers
    bucket mods

    2 weeks ago I ran 71.8 and 71.4 consistantly. I haven't been able to tune much but I did take the pump back off today to remove the small cone in front of the impeller and re-yamabond the pump. I then changed the plate's shims b/c I suspected drag. I had J-gapped plugs that installed and also indexed them with my kit I got last week. Today I was in a crunch for time as it has been raining on and off for the whole day. I decided to try and make it out for a couple runs. at 897ft 75* 87% humidity I ran at 74.8 mph GPS then 74.5 on my second run. didn't have time for any more. I haven't tweaked my EFI much more than 20 minutes worth. haven't found the sweetspot there yet.

    First off I'd like to thank SpeedJunky(kevin) for helping recommend mods that would help me... He's answered so many questions (newbie/annoying ones) and helped a lot. Also thanks to Carl at IR and Jim for helping me as well, both have answered multiple phone calls from me. Thanks to everyone for your help.

    I'm not content yet. How much more speed is expected from tweaking the EFI? I guess its hard to tell I could have it dead on but that is unlikely. I feel like I'm running rich but don't want to lean her out too much. Is there a kit for removing trim tabs? I suppose you'd want to fill the holes up with a bolt or something yet I want to be able to install them if my results aren't good.

    Is there a hidden post on tweaking the EFI? search shows nothing.

    Thanks EVERYONE and thanks to greenhulk.net for existing.


    Ben
    What kind of RPM's? Where the 71 MPH runs lacking a little bit in the RPM department? If not you may be able to do a little prop tweeking and get those numbers even higher.

    Great job!!!

  5. #5
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    i never got RPM readings I got my PET from watcon when I got the index kit. I need to buy wire and get it set up and I'll be able to get a good reading. I may send my prop to carl as I dont' have a prop measuring tool. thanks guys.


    Ben

  6. #6
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23

  7. #7
    that is awesome! you picked up 3 MPH from removing the cone and indexing the plugs??

  8. #8
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    the plugs I put in were J gapped and it idled very smoothly. I'm very happy with the idle and I think it may have helped some on top end.

    but I did change the angle of the plate slightly. I might have had drag on one front corner of the plate but I'm not sure. I'm leaving the plate where it is for now.


    that thread really helps RX951. thank you



    Ben
    Last edited by IowanGPR; 05-27-2007 at 12:31 PM.

  9. #9
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Great job Ben, Some great numbers with your ski.

  10. #10
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,340
    +1
    121
    Nice numbers!!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My new RXP pictures.
    By dgmoore in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 04-28-2013, 10:51 AM
  2. WFO Performance and my new numbers
    By jeffsntx in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 04-04-2007, 09:02 PM
  3. New numbers on my wife's XLT1200
    By Chezzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-07-2006, 09:38 PM
  4. New Numbers with my 03 EFI
    By GPGA in forum Yamaha PWC Performance (2-stroke)
    Replies: 46
    Last Post: 02-01-2006, 08:48 PM
  5. My new piggyback fuel controller with bigger injectors
    By Green Hulk in forum 4-Tec Performance
    Replies: 18
    Last Post: 06-17-2005, 02:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •