Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Still porposes with RE's

    Just put the RE's on my RXP and still it porposes? Going 73.4 with 3/4 tank of fuel on flat water. Last year I was at 72.0 and now I added the Riva 4in. rear intake, Riva grate, wedge and 81mm nozzle. This thing used to shoot gobbs of water out the back now it's a flat rooster tail.
    Anyone know what causes this?


  2. #2
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    mine is the same way unless i let off the gas and trim the nose down...it did cut down a little but not the claimed all ...

  3. #3
    wavehummer's Avatar
    Join Date
    Jan 2006
    Location
    Phila. PA 19154
    Posts
    594
    Just from reading some other post, it seems the wedge may be the cause of it.
    But I don't know personally if thats the case.

  4. #4

    Join Date
    Jan 2006
    Location
    Puerto Rico
    Posts
    691

    Smile

    Quote Originally Posted by Sandy View Post
    Just put the RE's on my RXP and still it porposes? Going 73.4 with 3/4 tank of fuel on flat water. Last year I was at 72.0 and now I added the Riva 4in. rear intake, Riva grate, wedge and 81mm nozzle. This thing used to shoot gobbs of water out the back now it's a flat rooster tail.
    Anyone know what causes this?
    Of course i know, remove the wedge and try againg

  5. #5

    HEY!!!

    remove wedge and try !!!! see were your trim is set at when its full trimed

  6. #6

    Thanks for the help!

    This thing plows through the water. I always thought the wedge would bring the front up. I've had the trim up and down. It seems like one click below center is giving the best speed results. (I have no extension rod for the wedge). I just thought the nose would be up higher. Does the Riva Grate suck the front down? Is the grate even necessary for Stage 1 Mods. I'm always on flat water. Thanks!

  7. #7
    BlaZinMJ's Avatar
    Join Date
    Aug 2006
    Location
    Wyomissing, PA/Ocean City, MD
    Posts
    1,063
    if your always on flat water, then the riva grate is the only way to go

  8. #8
    ROTAX RACING performance
    Join Date
    Apr 2005
    Location
    sweden
    Posts
    1,462
    +1
    17
    take the wedge out!

  9. #9
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    i dont run a wedge and the ski still does it....but i need to hit a small wave to get the thing to start and once it starts it wont stop till i slow down or trim the bow down...

  10. #10
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,759
    +1
    29
    If your running flat water with a wedge and RE`s, you`ll lighty porpoise. Mine still does but I`m rarely in flat water. Wouldn`t think of removing my wedge. I like air.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 Sea Do XPL...Help with re-installing engine wires
    By greenbuggy in forum 2-Stroke Performance
    Replies: 1
    Last Post: 04-05-2012, 10:15 PM
  2. Does the learner key still work with a rr ecu?
    By rxp747 in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-06-2011, 11:30 PM
  3. Need help with RE's block offs
    By BlackHawk in forum 4-Tec Performance
    Replies: 45
    Last Post: 12-06-2009, 04:03 PM
  4. RXPX Still stuffs with holes drilled ******
    By rxpstan in forum 4-Tec Performance
    Replies: 49
    Last Post: 07-18-2008, 11:16 AM
  5. Does rxp cover still fit with throttle conversion?
    By chitownrxp10 in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-05-2006, 04:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •