Results 1 to 3 of 3
  1. #1
    rxp_boy's Avatar
    Join Date
    May 2005
    Location
    Malta
    Posts
    251

    Installed Piranha Frount Mounting, now lot of vibration

    Hello

    I installed the piranha front mounting on my RXP, when I started it on trailer the vibration was more than it was with stock mounting.

    Tried at sea and vibration is hell, changed even engine noise !!!

    IS it normal ???? or is there anything wrong ???

    Please tell me your thoughts, this Jetski is making me sick with probs at just 85 hrs


  2. #2
    OK, was there shims to put back? Sure you not out of engine alignment?
    also the Rotax and Piranha mounts are more stiffer, less movement, so Yes you will feel more engine Harmonics/vibrations...PR...

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    I get some vibration out of mine ..nothing severe thou...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How-To: Bilge Pump Installation in an RXP-X (Lots of Photos)
    By RobWCanada in forum Sea Doo How To & FAQs
    Replies: 46
    Last Post: 08-11-2013, 07:37 AM
  2. lots of vibration 701 Waveraider
    By wave raider 97 in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 08-08-2013, 08:16 PM
  3. How-To: Bilge Pump Installation in an RXP-X (Lots of Photos)
    By RobWCanada in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-28-2010, 01:56 PM
  4. Lots of people online right now crazy...
    By yellow4 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 08-07-2007, 12:53 PM
  5. Replies: 7
    Last Post: 01-06-2007, 03:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •